All posts related to V2
By chrisnvp
#314802
Hey all
When I export my rendering out of Studio v2 and choose the "material ID" and "Object ID" channels, why are they rendering like the render channel. As a result I'm getting all kinds of noise in these channels - which completely defeats their purpose.
In v1.7 they use to export as perfectly clean image maps of the object and materials as soon the rendering started.

Any suggestions?

Thx
Chris
User avatar
By Mihai
#314836
In 1.7 these channels renderes before the main render, and they were limited in the way they calcuated transparencies and depth of field, plus they where separate channels. In V2 they have been improved and they are part of the mxi file now which means they can be resumed and can also work with network rendering. As the render progresses they get cleaner, it's only at lower SL that you will see strange noise in them.
By chrisnvp
#314839
That's disapointing..... I think.
I like the way I could get a quick material map of any scene.
Now I have to wait until the render is at a high sample level?? My sample level was 12 and it still had lots of noise. Seems like the v1.7 way still has alot of merit. Maybe offer both for various workflows. :wink: especially since most architectural rendings don't have depth of field issues. I just need a quick and clean material map. For the transparencey issues in the mat. map in v1.7 i just exported a separate mat. map where I replaced transparent materials with solid ones. (still way faster than waiting for a high sample level although this doesn't work if you are trying to edit the material behind the transparent object.)

Both options would be very handy...... any chance of bringing it back.

Thanks for your reply Mihai
C.
By brodie_geers
#314841
Mihai, that's interesting, I haven't had a chance to test mat/object id's yet. So are you saying that they now work more like, say, an alpha map where it gets cleaner and cleaner over time instead of a one shot deal as in 1.7?

-Brodie
User avatar
By tom
#314854
No, 1.7 was not better at all. Let's remember how is it working:

Render > Continuous
Shadow > Continuous
Alpha > Continuous
Object Id > Limited*
Material Id > Limited*
zBuffer > Continuous

(*) The limited ones were quickly pre-rendered so, most of the time they were not noisefree. e.g. it was not possible gather a noisefree dof, etc.

Now, all 2.0 channels are continuous and stored in MXI. Therefore, they are also supported in cooperative network rendering and resuming, too.
User avatar
By Mihai
#314862
chrisnvp wrote: I like the way I could get a quick material map of any scene.
Now I have to wait until the render is at a high sample level??
You can always deselect the main render channel and just render the matID.....

I don't understand the workflow, I mean you could get a matID quickly, but what would you use it on? The main render would be far from finished. Besides for higher rez renders, you had to wait first for the matID/objID channels to finish rendering first, before the main render even started.
By chrisnvp
#314870
So after rendering to SL. 12, is this going to be normal or am I doing something wrong?

ftp://trouble.finelineperspectives.com: ... tives.com/

In the Obj.ID you can see a ton of noise, especially in the lower half of the image.
The Mat.ID is has a different issue that concerns me. Most of the materials just export as grey and still with a lot of noise.

I don't understand the workflow, I mean you could get a matID quickly, but what would you use it on?
Sometimes i forget to choose the mat.ID and obj.ID channels before I render. so it's nice to be able to get it quickly. (I know...weak right?)

Thanks for your time.
C.
By rusteberg
#317997
Mihai wrote:You can always deselect the main render channel and just render the matID.....
when i deselect the render channel and select only other channels, maxwell omits the render channel and processes only the channels i assign when rendering from 3d Max.
when i send scene through network, the render channel gets rendered no matter if it's enabled or not....... no bueno.
Texture/finish lost in render.

Nothing?

I answered this question myself in Rhino 6 documen[…]

New developments for Maxwell 5.1

- First one the random color don't work with hdr[…]

Material preview

Yes, I have set Maxwell for Rhino as Current Rende[…]