User avatar
By Maximus3D
#293256
Hi

I'm having some trouble with materials in C4D r11, it seems that when i create a Maxwell material and click the 'Link to' button to pick a material from my collection it rarely loads the one i pick. Sometimes it works but most of the time i end up with a standard grey diffuse material instead.
The path to the material is correct so it should work. Also i cannot drag a material from the browser to my scene or to the materialswindow in C4D, i mean you can but it creates a new scene with that material, it's not just adding the material to my current scene.

And also if i open the MXED Editor from within C4D to load a material from it instead, nothing happens. The material i loaded never shows up in the scene. It dissapears the second i close the MXED Editor. Same thing with the Browser as i described above, not working very well.

So far the only way i been able to use Maxwell materials is either by pure luck manage to import one from my collection or to create one from scratch within C4D.

Anyone else have these issues ?

/ Max
By JDHill
#293272
I'm having some trouble with materials in C4D r11, it seems that when i create a Maxwell material and click the 'Link to' button to pick a material from my collection it rarely loads the one i pick. Sometimes it works but most of the time i end up with a standard grey diffuse material instead.
The path to the material is correct so it should work.
Regarding this, I will probably need some more detail, since it works fine here. How it should work is:

1. click Plugins > Maxwell > Material
2. in the AM, click the [...] button under MXM Linking to browse for an mxm file
3. using the file-picker dialog that is shown, choose an mxm file, then click OK

At this point, the chosen mxm has been read into the material, and the 'Link to' checkbox has been checked in the AM. The preview in the AM and in the Material Manager show a green border, indicating that the material is linked.

If you then:

4. click the MXED Editor button in the AM
5. change the mxm when it is shown in MXED
6. File > Save
7. close MXED

Now, the changes which were made in MXED are shown in the AM, the Materials Manager, and in the plugins Material Editor. The material is no longer linked, and the preview in the AM and in the Material Manager no longer show a green border.
Also i cannot drag a material from the browser to my scene or to the materialswindow in C4D, i mean you can but it creates a new scene with that material, it's not just adding the material to my current scene.
There are two places you can drop MXMs: the Cinema Materials Manager, or the preview in the plugin's Material Editor. If you want to drop them on the Materials Manager, they have to have been dragged from the Content Browser; otherwise, if you're dragging them from Explorer or MXED's Browser, you need to drop them onto the plugin Material Editor's preview. I would like to make it work differently, but it is not possible due to limitations in the Cinema SDK.
And also if i open the MXED Editor from within C4D to load a material from it instead, nothing happens. The material i loaded never shows up in the scene. It dissapears the second i close the MXED Editor. Same thing with the Browser as i described above, not working very well.
It is not meant to be used this way. Mostly, you should only use MXED when you want to use something that's not yet implemented in the plugin's own material editor, like some of the advanced wizards. When you do, the plugin has to write a temporary mxm file and open MXED up using that - if you then use File > Open, or Save As, you will no longer be working with the same mxm file, so you won't get any useful result. If you want to use MXED anyhow, the way to do it would be:

1. create a material
2. click MXED Editor
3. right-click the layers tree and choose Embed MXM...
4. choose an mxm file
5. File > Save
6. close

I'd recommend using the plugin's material editor though; it's quicker and more convenient, i.e. you can dock it in the Cinema window, and you get real-time feedback in the viewport for changes to color/roughness/etc., where you obviously will not when using MXED.
User avatar
By Maximus3D
#293273
JD, thanks for your reply. It's helpful, from what i can see it looks like it's a user error at the moment. :(

But i don't think the thumbnails are updated when you're linking a mxm in, or they are very rarely updated. I get that green border around the material but it still remains the standard diffuse grey when i doubleclick on it in the C4D materialwindow thingy. Perhaps this has to do with it not being updated/refreshed properly as it's linked in from a external mxm file. I don't know..

About dropping materials into the scene, ok i'll try that again and see if i can get it to work now. Thanks for your description.

/ Max
By MS
#293293
Maximus3D wrote:... it still remains the standard diffuse grey when i doubleclick on it in the C4D materialwindow thingy. Perhaps this has to do with it not being updated/refreshed properly...
Right click on a material thumbnail in "Material" window in Cinema and choose "Render materials" or "Render all materials". It should update thumbnails.
By JDHill
#293307
Actually, I can now repeat this particular case. I mean:

- create material
- click MXED Editor
- refresh preview
- File > Save
- close MXED
- preview is not updated

It is one of those lovely inexplicable bugs where it is working fine in a debug build, but not release - meaning, the code is no different, but the behavior is. So I'll be looking into it. In the meantime, I would again recommend using the plugin's material editor instead of MXED.

Hello Achim, We won't officially support it until[…]

Hello! We have just released a new version of the[…]

Let's talk about Maxwell 5.2

I have to say, as I've mentioned before, getting 1[…]

New podcast - CG Talks

Hi guys! We've just finished the first season of […]