By JDHill
#294073
Thanks, it should also work fine with 64bit though, so I'll still try to see if there's anything peculiar about XP x64.
User avatar
By macray
#294087
It works fine with me under XP64 running Cinema64bit.

But I have one question:
- I use loads of XRefs with Cinema materials, but the materials don't show up when rendering with maxwell. All I get is the model using some white material but that is not intended.
Is there any restriction regarding Xrefs?
By JDHill
#294093
Thanks for the info; I'll still try to get XP x64 going here anyway, since I'm pretty sure it's only being tested on Vista x64. Regarding Xrefs, no I'm not aware of any restriction, meaning that the plugin searches any Xrefs it finds recursively. So for example, I am testing here with a document that has an Xref to a document that has an Xref to a document with real geometry; there are both Cinema and Maxwell materials being referenced, and they're being found correctly, so if you could give me some more specific information about your scenario, I can try to duplicate the issue.
User avatar
By macray
#294152
I'll try to repeat the test on this computer here running XP32 to see if it is the same here. Will do it today in the evening, so no response until tomorrow, but thank you for taking a look into it.

(basically I can say that I built the model in cinema and until now there are no maxwell mats used. To transfer it to the other computer I saved it as a project in cinema thereby having the main file and 27 different Xrefs being in the same directory not referring to anything else but containing the necessary things.
When rendered separately they show the materials but on xp64 no material popped up.)
User avatar
By macray
#294175
had it rendering during my lunch break - here are the renderings.

http://pics.livejournal.com/macray/pic/000p3dbb <-Cinema

http://pics.livejournal.com/macray/pic/000p4ztt <- Maxwell

the chairs are equipped with a black material. They are Xrefs as well as the boards, the tables and the other equipment in that room. The door is in the original scene and thereby having a material. Even the lamps are Xrefs.
waht I did in most of the Xrefs - put the materials in a layer that is named according to the object. So if I ever copy this model to another scene I have easy access to the materials regarding this model alone. Maybe this layer for the materials is ignored?

- on xp32 using Cinema R11.xxx whatever was there to download today + maxwell1.8.1.5
seems like it is not just xp64 related but comes from something else.
User avatar
By macray
#294227
me again, sorry for the triple post

Found the reason for the issue: Xrefs have to be on top of the object hirarchie and not in any other object. I used to group them in null-objects as there are loads of Xrefs in the scene.

Will this be possible in future versions of cinemaxwell? To group Xrefs and still have their materials rendered? It's funny that they show up but their mats are not shown...
By JDHill
#294233
Thanks, I've confirmed this and fixed it for the next release.
By garbage75
#295479
Hi at all,

I've got a very bad trouble with cinemaxwell 1.8.1.5 and Cinema 4d 11 under OSX. It seems that the plugin does not work in every situation... I already ask for italian forum.. but no one encountered the same problem..
When I open a simple scene and try to render, the two attached error message appear.. and MXCL close... what's happen?
I attach also a simple scene that I made for the one who could test this situation.. I already try every step that I could wonder... uninstall and re install the plugin.. uninstall and re install MAXWELL... try to repair the permission on macintosh HD... I don't know what to do... cinemaxwell NOT WORK AT ALL!
Thanks to everyone could give me the solution.

Image
Image
http://digilander.libero.it/walterfog_75/mxcl_error.zip
By Mr. Gog
#295485
It works well here!

Maybe you are pointing to a network drive that doesn't exist. Or maybe it's not a mounted volume.

Avoid the use of extrange caracters in any folder or subfolder in wich it's contained the mxs, included the hd or volume.
By garbage75
#295487
I have no network drive... and no mounted volume.... nothing at all..
I only simply have the macintosh HD and another internal disc.

And I not have used no strange caracter.. subfolder... nothing of this kind.. I only have the folder that you could see inside macintosh HD... only this!!

And the same error happen in the MACPRO and in my MACBOOKPRO.. the same message and same error!!!

What's happen??
By garbage75
#295491
I try to re install the plugin version 1.7 and everything goes OK.

In fact as you could see from the MXCL consolle it read the right MXS file inside a macintosh HD and "scena_Walter" folder.. as it is and as I set with the maxwell render settings TAG inside cinema...

if you could see from the past imagine that i post, the 1.8.1.5 plugin version write a wrong path for the MXS file... could you see the double slash "//" from the MXCL consolle?
That's wrong cause the MXS file is inside macintosh HD and the "scena_Walter" subfolder... and inside cinema with the scene TAG I set the right path.. the error is caused when cinemaxwell write the MXS and start MXCL..
I attach the 1.7 plugin consolle version!!!
I hope that now is clear and someone could help me please!!!!

Image
By JDHill
#295498
The only way I can make that happen here is if I type a / into the Output > Folder path
of the Scene Object. However, in the file you uploaded, that is blank, so it shouldn't be the cause - have
you tried specifying the output folder directly instead of leaving it blank?
By garbage75
#295501
Hi JD thanks for your reply..

so if I leave the path blank the plugin work well and the render start...

if I try to browse the right folder where is the cinema file, the plugin give the error you saw.. he write 2 slash "//" and that's why the disk network error appear...

if I manually write the righ path the same happen... he write "//" again...

The only way to make it working, is leave blank the scene tag inside cinema... :shock: :shock: :shock:
By JDHill
#295502
I don't get that behavior here. If I put your folder, scena_Walter in the root of my Macintosh HD, then browse
there from the plugin Scene Object's Output > Folder button, it is shown as pointing to /scena_walter.
Are you sure there is not maybe a folder with a blank name in-between, causing the // to appear? If I can repeat
the behavior, then I can look into the code to see if it's caused by the plugin, or at least if the plugin can detect/fix it.
By garbage75
#295505
Me again.. when I put the folder scena_Walter in the root of macintosh HD and then browse there from the plugin Scene tag I see /scena_Walter, but when I start the render, in the MXCL consolle I see two "//"... and I don't know why.

What you mean with a folder with a blank name in-between, causing the // to appear?

sorry but my english is not very good!!!

Thanks, Luis, appreciated. It looks like industria[…]

That looks like a low bpc (bits per channel) norma[…]

Fully working plugin for C4D

When you will be working on it please try to keep […]

Let's talk about Maxwell 5.2

Is there any update regarding CPU engine ? Som[…]