By martyc
#286370
I've have a problem getting the pluggin to load the Maxwell Render portion of the Maxwell pluggins for Lightwave (8) PC XP. I get the editor to work through the surface shader, also all the Max options, but where do I push the render button? F9 goes straight to the typical LW render. I've owned Maxwell for 3 years and have always a problem with simple S..tuff. I got the FormZ pluggin to work, the Maxwell Studio works, if I import the obj from LW, but it's too complicated when I want to animate, or just use an interface I'm familiar with. I've tried the configure file, Menu Branch, as suggested by Nextlimit, and cleaned up my directories, and re-installed LW twice, and latest pluggin etc etc . I see the Maxwell Render in the list of loaded pluggins loaded in LW, but not in the utility scene menu. No trigger to launch Maxwell render
User avatar
By Mihnea Balta
#286374
The installer will try to add Maxwell buttons to the "Render" menu group. This doesn't always work because it's implemented as a hack, since Lightwave doesn't have an officially supported mechanism for programatically adding buttons in the UI. If it works, it should look like this:

Image

If the installer didn't create the buttons, you can simply use the menu editor (alt+f10) to add them to the UI, which is the standard way of configuring Lightwave plug-ins. The commands are located under the "Plug-ins" group:

Image

Expand the Main Menu -> Render item on the right, select the first sub-item (which is probably called "Options") and click "New group". Rename the group to "Maxwell" and drag the commands which start with "Maxwell" inside it. You can rename the items after you drag them as shown in the first image, since some of the names are too long to fit on the buttons.

If I recall correctly, Lightwave 8 doesn't allow you to add menu branches from files. That feature was added in Lightwave 9. If you were using Lightwave 9 you could have imported "MaxwellMenuBranch.cfg" inside the menu editor instead of manually creating the group and dragging the commands into it.

The Lightwave SDK doesn't allow us to make the normal "Render frame" button launch Maxwell. You can use the shortcut editor (alt+f9) to manually assign the F9 key to the "MaxwellRender" command if you want.
By martyc
#286394
You really helped me friend, you wrote a tutorial that should be in the Maxwell for dummies book. I was trying to put a square peg into a round hole with that Branch Config file, since I have LW8. Thanks!!
New developments for Maxwell 5.1

- First one the random color don't work with hdr[…]

Texture/finish lost in render.

Anything?

Material preview

Yes, I have set Maxwell for Rhino as Current Rende[…]

Hello everybody, we have a problem with the Maxwe[…]