I get a consistent problem in Maya 2008 where textures display black outside of their initial UVs:


Note that the tiling is also a bug. If I move the UVs, the black area doesn't update unless I switch the resolution of the hardware preview in the mxm dialog so I have to try and lay out a partially black texture and constantly toggle the texture res to work. It's consistent across my Mac Pro and MacBook Pro. Is this a known issue?
By msantana
Regarding your first issue, have you checked if you have the wrap U and wrap V checkboxes checked on the file texture node of your Maxwell texture in Maya?

This is something you can fix in the MXM file itself (if you import them later into Maya) where you can check a checkbox that asks you if you want to tile a texture file.

I may be missing some names or misnaming something as I don't have access to Maya right now.

Hope this helps.
By cgbeige
The tiling isn't what I want to turn off - it's just not displaying the texture correctly. It's showing black where there aren't any UVs and then tiling the texture where the UVs end, not at the end of the texture. This is only in the UV editor though - it actually renders fine (no black and no bad tiling). But it makes it hard to work.
By msantana
Hmm this sounds then more like a video driver - Maya bug more than anything else.

With Maya 2008 for Mac I had worse video performance on Maya than with Maya 8.5. Some geometry is not being displayed correctly on my models or on worst occasions, not at all.

Textures are not being displayed correctly, so I tweaked the hardware renderer to display only very small proxy textures 128 x 128. Otherwise the application would take a huge performance hit. I am talking about a 600% or more performance decrease with trying to display 1024 x 1024, it is really that bad.

I have a Quadro FX 4500, which is a reasonable video card for displaying 4096x4096 textures and under OS X I have the aforementioned problems. But under the same hardware with XP x64 these go away.

I would be willing to point the finger to the video drivers in your mac.

Have you tried doing the same workflow but under Windows, perhaps with bootcamp? Not that this is a solution or even advisable if you have tight deadlines, but at least you would be able to pinpoint the problem to the drivers.

Please note that this is specific to the Maxwell textures, I have fewer headaches with the mental ray textures. However driver issues are still there.
User avatar
By Mihnea Balta
The black parts are a problem with how Maya evaluates plug-in materials. For some reason, Maya only computes the material color inside the UV space of the mesh, so the portions of the image which are not covered by any polygons will be black in the UV editor.

However, there's an easy workaround for this. Go to the "Textures" menu in the UV editor and select the texture you want to see instead of the whole material. You will see that the built-in materials (lambert, phong etc.) do this automatically, but I haven't figured out a way to do it for the Maxwell material without user intervention. As an added benefit, selecting the texture explicitly in that menu will make it show up at full resolution in the editor, instead of the preview resolution specified in the material attribute editor.
By cgbeige
thanks Mihnea - but the UV editor texture thing didn't change anything in the black areas.
User avatar
By Mihnea Balta
In this example, if "pPlane1 | maxwellMaterial1SG" is checked, I get the problem you're describing. If I select "pPlane1 | maxwellMaterial1SG | file1", the problem goes away:


Does it behave differently in your case? If it does, try closing and opening the editor, does that do anything?
By cgbeige
yes, I did that and it still doesn't fix the problem. I think the Mac version is different. My only workaround right now is to make a dummy lambert texture with the image to use as a UV layout temp.
Maya plug-in MR 5.2

For instance, I'm pretty sure that people would […]


Hello Paolo, If you prefer not to buy the plugin […]


Welcome back Ivox! It's nice to see you around. […]

One more test to add. This time with a created HD[…]