User avatar
By Daniel Hruby
#239927
When I save out of ArchiCAD and open the MXS in Studio, it has about 20% of the materials correctly linked to MXM files and the rest have my ArchiCAD material names with an X through the icon.

Since I use the diffuse maps in ArchiCAD to set the scale of the texture map, it is easy to be fooled into thinking the rendering is working properly with the assigned MXM files. Instead, it creates a basic diffuse texture with my maps. In hindsight I always though my materials were looking a bit flat. Now I suspect a flaw in the export.

The solution would seem to be to just correct the material assignments in the MXS in Studio, save and use the import to make any changes to my geometry while keeping the correct material assignments. However, my problems are now further compounded by the fact that Importing to update geometry crashes Maxwell 90% of the time. The other 10% will delete pieces of geometry that have not even been updated. For example, my window frames disappeared the one time managed to import geometry.

So, for me, one little change in my scene requires a tedious process of saving out a new MXS every time and going through the process of resetting up my scene entourage and correcting the MXMs. I lose about an hour to this cycle every time I have to redo it.

Has anyone else noticed this when opening an ArchiCAD exported MXS?
By pelias
#242968
Daniel Hruby wrote:When I save out of ArchiCAD and open the MXS in Studio, it has about 20% of the materials correctly linked to MXM files and the rest have my ArchiCAD material names with an X through the icon.
2 points here:

- X through the material icon in Studio is easy to explain - this is due to a missing material preview for a particular material. As the material was generated from ArchiCAD directly (it is not linked MXM) the preview is missing (nobody generated it) and hence the X in the preview. Open the material in Studio, generate the material preview and it will go away...

- Loosing MXM material assignment when exporting from Studio is something which I haven't experienced myself. Any more info on that one? Can I get a sample scene showing that?

Pavol
User avatar
By Daniel Hruby
#242994
Pavol,

This happened a while back. It was in part due to me moving the materials library in the maxwell folder. ArchiCAD file was referencing those materials and could not find them. Instead, it was sending over the maps assigned in archicad and using default shader values + texture-maps from archicad. So I got a rendering that looked correct, but had horrible performance and flat looking images due to the default Lambert setting issued from the plug in. (Anyway you can set those values to export a 95% roughness for a default?)

To avoid this problem in the future, could the plug-in offer a library selection to point the MXS to the correct library for a situation where one moves the material library after assigning a ton of materials? I can think of another example, I work on a project in my office and bring it home to render over the weekend and I need to point the plug in to the MXM library on my home machine.
By pelias
#243008
Daniel Hruby wrote: So I got a rendering that looked correct, but had horrible performance and flat looking images due to the default Lambert setting issued from the plug in. (Anyway you can set those values to export a 95% roughness for a default?)
This is already done as you've requested - just wait for new version of the plugin which should be released shortly...
Daniel Hruby wrote:To avoid this problem in the future, could the plug-in offer a library selection to point the MXS to the correct library for a situation where one moves the material library after assigning a ton of materials? I can think of another example, I work on a project in my office and bring it home to render over the weekend and I need to point the plug in to the MXM library on my home machine.
Let me thing about this a little - I see that it make sense when moving project between machines...

Pavol
is Maxwell Render abandoned?

Do you mean that jazz tune that sounds like Jolly[…]

FormZ 9 support

Please, PLEASE keep up support for FormZ. It's a k[…]

Maxwell Render 5

Good question. Their was a link in the announceme[…]

after quitting because the LW plugin was discontin[…]