Everything related to the integration for Rhinoceros.
Hello everyone ,

After my last setbacks with the Maxwell for Rhino plug-in, corrected by the manual replacement of 2 files (see other post) :D ,

I had another problem yesterday : :(
Maxwell render no longer worked because the OpenCL.dll Dll was missing.
To correct the pb, since the reinstallation did not work, I copied this dll present in my Maxwell 3 directory (C: \ Program Files \ Next Limit \ Maxwell 3), in the Maxwell 5 folder (C: \ Program Files \ Next Limit \ Maxwell Render 5), which works.
:D :D :D

Today 2 new problems :
I create new opaque materials by clicking on the icon provided for this purpose in the next plug-in toolbar (which I have thanks to the 2 correction files, suddenly :D ).
I just load a texture on the color line in channel 1:
-If it is in cmjn jpeg and it has 100% black elements, the black does not appears in the fire, the rhino rendering mode and the final rendering. :evil: => You have to put the texture in png (RGB) format before, so that the black finally appears.
Ok it wasn't easy to fix but it's good.
:D :D :D

- On the other hand, when you click on "Convert to advanced" (Maxwell Material / Global properties / Opaque window), and then you continue to create your others opaque materials, something strange happens:
Indeed, the textures of your previous materials switch randomly on channel 2 !!! :( :( :(
Suddenly the fire no longer works and you have to constantly put all the textures on channel 1 !!! :twisted: :twisted: :twisted:
Not to mention that a second texture loading window can open simultaneously with the first one and that Rhino can simply end up crashing ...
:twisted: :twisted: :twisted: :twisted: :twisted: :twisted:

I specify that I saved the materials in .mtl also

Am I a black cat or what?

I specify that I am under win 10 version 2004 and unfortunately still equipped with a Quadro K4200 graphics card for the moment.

Did you have this problem ?

Here is my conclusion for the moment :
1-The only way to go to the end is to ignore the problem in Rhino.
So, to see the placement of textures, in rhino rendering mode, you have to click on "convert to advanced" after creating the opaque material.
It is thus possible to adjust the plating of the materials.
2- Record the mxs of the scene and open it in the studio
3- Start the fire; which does not work suddenly, but generates the error.
4- Open the console to see the problem.
5- Correct the channel (s) in the responsible material (s): put 1 instead of 2
6-Save Mxs and start renderings...

I remind you that normally we are supposed to do without buying a studio license ...

Fortunately, old Maxwell users are far-sighted!
8) 8) 8)
Hello Thierry,

Thanks for the feedback!

Regarding the OpenCL.dll file, I would suggest deleting it and updating the graphics card driver. It should be provided by it and will work better.

Regarding the jpg file, I don't understand what is a cmjn jpg (cmyk maybe?). When you say the black doesn't appear in Fire, what does it appears instead? Could you show a screencapture?

I can confirm the bug with the channels when converting to advanced, but you can change the channel of the texture from Rhino too:
Texture channel in Rhino.png
In any case, I'll make sure this doesn't happen in the next version (hopefully the following week).

You do not have the required permissions to view the files attached to this post.
Dear Fernando,

My PC has just been updated to the win 2004 version; I don't think that the driver of my quadro K4200 card is old ... well I would look ...
Anyway, I have to be changed this card ...

Cmyk = cmjn in French, you're right Fernando.

For the texture channel problem, I know you can fix it in Rhino ... but like I said before, the problem is random ...
For example :
You can make a correction in a first material and the problem will appear on a second ...
You correct the second and the problem comes back to the first or third ...
In the end, you can correct the same material several times ... you just have to have time to play with it!
Me, I stopped playing and taking the lead, that's why I finally used the Studio to fix it.

For the problem of the disappearance of black in the textures jpg in CMYK, I give you 2 captures (in the rendering mode of Rhino; it is the same in Fire mode).
One with the texture in CMYK jpg and the other in png RGB. In Jpg, you can already see that black doesn't appear in the texture window.


Don't pay attention to the color difference between CMYK and RGB, it's normal ...

Hey, by the way, I just switched the jpg to RGB to see ... and the black reappears ...

=> Morality: Remember to change the texture mode before using it with Maxwell and Rhino: Always use textures in RGB !!!


Have a good day !

Hi! I have looked for the answer to this but so fa[…]

Settings do not stick

Quick update - if you save the viewport again (in […]

I don't understand why it is so difficult to have[…]

Backplate rendering - reflections

Ok, thanks, so Arnold can do https://answers.arnol[…]