Everything related to the integration for Rhinoceros.
We're experiencing crashes when applying materials in the new version of Maxwell for Rhino (OS X). Here's what happens:

In both the layers panel and the material editor in Rhino (or even when selecting by object) there is a drop down menu that appears called "name and type", when we select "Maxwell Referenced" the program crashes every time. We haven't been able to apply Maxwell materials since making the upgrade. We installed the original version and updated to the new November 27 update with no improvement.

The attached images show the situation of what we select to cause the crash.
You do not have the required permissions to view the files attached to this post.
Hi Deirdre,

I'm currently in the same situation where Rhino 6 is crashing a LOT of times for various commands !
As I can't have R6 and R5 on the same machine (one shared folders !?!?), I can't go back to the old setup RH5-M4, which was not well integrated, but at the end of the day it worked because of studio.
So now I'm stucked with a clumsy package and no help either…

As an OSX users, don't you think that our community is a bit ripped off with this new maxwell version ? I mean that the new devlopment is CUDA -GPU oriented, which will never happened on apple machines. Do you think there are new intersting features ?
We've figured out a series of work arounds to get Rhino 6 + Maxwell 5 working somewhat, but it's still quite constrained. The promise of a well integrated OS X version of Rhino and Maxwell working together is exciting, but this has definitely been a disappointing introduction of the new software.
Having similar issues..

To me it appears that:

1. There is very little open communication about the progress or knowledge of possible fixes to these problems, as well as the future of the integrated materials.
2. Maxwell for Rhino is not working on a sufficient level to be considered what is promised.
3. I personally am losing trust in this franchise due to the lack of open communication in threads such as this.

I just upgraded to Mx5 with the thought that it will be workable with Rhino6 on osx, but this does not appear to be the case.

It would be good to see some answers in these threads, otherwise I will just have to go for refund and quit using Maxwell as it does not Work.

When I started using Maxwell 3 for Rhino it was easy and reliable, it was truly a joy to work with this setup, but it has been some time now.
Well. I'm not up to date on everything as I'm on vacation. But AFAIK we should be releasing new maxwell version soon, and this version will have new plugin version for every plugin and some new too. Specificaly quite a lot of fixes for mac. I would wait to test this new version.

When I'm back at the office I will suggest some changes on communication about plugins, as I think our main lack of communication is here.

Add me to that update when you know more please. I am also waiting for some resolve here. I am having very similar issues with Windows Rhino 6 +V5.

The only workflow that has worked for me is the old Rhino 5 + Maxwell 4 - before the UI change. Once the UI changed to be more "integrated" I haven't been able to use it.
I've been using Vray for the last year now... it's just not the same. I prefer Maxwell, even as slow as it is.

So please get this sorted out for us!


We have just released a new version of Maxwell and several plugin updates, Maxwell for Rhino, among them, however, the issue you described is not fixed as it depends on McNeel, not us. It was reported some time ago to their developers and it is supposed to be fixed for Rhino 6.23 (as stated in their log); if I'm not wrong, it is a bug in their SDK.
The crashes happen when adding a Maxwell material or environment from a floating window. The workaround is to create and assign the materials or environments from the general panels (usually the lower section of the side panel) and not the object-specific panels. In order to assign a material to a layer, you can right-click on a material and then Assign to Layers of Objects. In the case of the environments, you can open the environment panel and edit them from there.

I hope this helps.

Kind regards,
Thank you Jonathan,

I have passed the message to the team. It's great to have positive feedback from the user's side. :D

By the way, the integrated material editor is getting closer. It hasn't made it to this update as it required more work and testing but it's closer now.

hardware question :)

1) Start considering the actual hardware shortage.[…]

New podcast - CG Talks

Hey guys! We have just finished the second season[…]

So I've jumped into Maxwell again after a few year[…]

Let's talk about Maxwell 5.2

I stick to Maxwell for now only because the easy t[…]