Everything related to the integration for Cinema 4D.
User avatar
By LivVis
#401334
Hey everyone

Whenever I try to start and upload a cloud render job right from Cinema 4D, Maxwell Render stops working as soon as I hit "Finish" and the Spinning Wheel of Death shows up. Then, as soon as I quit Cinema 4D which is still active in the background, Maxwell immediately crashes and Cinema 4D quits regularly. So it almost seems that Cinema ist holding back Maxwell which doesn't make too much sense…

Anyone having the same issue? I feel like going crazy trying to figure this out since days (!!) while having urgent render jobs to be done…!

My specs:

Mac Pro (the black trash bin, 64GB RAM), first tried with MacOS BigSur then updated to MacOS Montery (= no difference…)
most recent Maxwell Version 4.2.2/4.2.1
Cinema 4D R25

I already checked any textures (and paths), I even tried with an almost empty scene (a plane, a sphere, no textures) and it still doesn't work.

Thanks a lot for not letting me go crazy…
#401335
Hey there. I have had a few problems with the cloud rendering and the Maxwell support team (via the client portal) has always been very helpful in resolving issues and coming up with potential solutions.

Whilst I have not had the same issues as you describe, probably because I use SketchUp on a PC, I prefer not to directly send the project to the render cloud.

Have you tried saving the scene as an .mxs file from Cinema4D? You then have to open the Maxwell Monitor (Blue coloured icon), log in and upload manually. The same dialogue will open for your project name and settings etc and the same finish button. If this crashes, then there may be something wrong, or corrupt with your scene file rather than anything Cinema4D related.

This may also be relevant: I recently had an issue with one scene in particular that would not send to the cloud either directly from SketchUp, or using the method I describe above. I managed to find a workaround, by saving the scene to the windows 10 documents folder on C: Drive. I all else fails, try saving your scene to your root Mac directory/Drive, or the root Maxwell scenes folder- whatever is equivalent for a mac!. Just a thought.
#401340
Thanks for your answer. I tried to fix it for days, my client‘s deadline is getting closer and closer, and Maxwell is really messing things up. I‘m sorry to say that Maxwell seems to be the most delicate and unreliable software I‘ve ever used and I start to regret I ever jumped on that train for archviz projects… :(

By now I‘ve gone through every option, tried all of your suggestions, checked every path in every material (100 or so), rechecked every reference file (although I used them in earlier projects without any issues), tried „pack an go“ which made it even worse: now I can‘t even render my scene locally because Maxwell claims to not find texture files which are clearly there at the given paths. I even opened these texture files in PS (altered them a bit) and saved them under a new name, relinked them in the material just to find that Maxwell now claims to not find the next texture.

I am really at my wit‘s end.

The scene I try to render is even smaller than previous scenes that were more than double the size (1GB!) and rendered just fine weeks ago.

So if anyone could help in any way, please…
#401341
Maybe try substituting another material for the one which you believe causes the file crash and see if the render goes through without crashing. If it renders okay, the problem is with the material so try downloading it again and see if it works. Alternatively, it might be worth creating your own material based on the settings and texture maps from the original?

Also look through the Console Tab in MR as this may provide a clue to what isn't loading correctly or causing an issue?

As a general work flow suggestion, do a SaveAs on your working file periodically to create a newer file, then continue with that. After doing your test renders, do another SaveAs and overwrite the earlier file. This gives you 2 working files so if you accidentally stuff up in one (delete things and not realise until way later) etc., you have the other working file to go back to without too much loss of work/time. If you do have earlier files where the test renders worked, is it possible to check what you did or changed/added after that file as that may give you a clue on where to look. It sounds like something might be corrupted ? I haven't yet used the cloud rendering service and from memory only had a file do something similar back in v2, I think, and we traced it down to a material from the old Maxwell library. Hope this help.
#401342
Sorry to hear of your ongoing issues with Maxwell. I used to have awful problems with supposed missing textures when using 3rd party render farms before Maxwell Cloud. The Maxwell Cloud seems a lot less fussy and even offers to replace missing textures with generic ones when it detects missing files, or to reuse duplicate named textures that may be located in different folders locally.

The fact your scene is now not even rendering locally is very strange. Sounds like you have done a thorough check on all paths etc. If you have access to Maxwell Studio, it would be good to see if things are better there. I have had situations in the past where Studio renders what the SketchUp plugin couldn't, although that was a while ago now.

Does the scene render if you completely remove all materials? Are you using MXM references, or are they embedded in the C4D file? SketchUp has an option in the Maxwell scene manager that allows to set the path of mxm files, as well as the search depth and you can add several different search paths. I presume C4D also has the same, so maybe you need to increase your search depth? Maybe some Maxwell setting have been reset following a recent update?

https://nextlimitsupport.atlassian.net/ ... references

Could you share a screen shot of your Maxwell Console showing what the errors are?

Last resort- Reinstall Cinema4D vanilla, and only Maxwel plugin. Perhaps some other plugins for C4D are interfering?

Not really sure what to suggest other than getting in contact directly with Next Limit support and detailing your issues there. Other than that, sharing the Maxwell MXS scene and textures via a dropbox or similar would enable testing on another machine. Obviously this is often not possible, so if you have another computer, even a laptop you can install Maxwell and C4D on, see if the same issues persist. DM me if you don't want to publicly share any link and I will see if I can help get to the bottom of this.
#401344
Thank you both for trying to help. I started another render this morning and changed the duration from 840 to 720 minutes. Suddenly the render started locally. I stopped it, went back to cinema 4d, turned it back up to 840, started the render: AND IT CRASHED AGAIN! This is super weird. And it is replicable. Those are the kind of bugs I really can't stand :evil:

Well, now I have one local render manually stopped at 9h, let it denoise, and now I'm getting square fireflies for the first time with this scene… I'm just about to start screaming and laughing hysterically :cry:

By the way: I'm creating most textures and materials myself. There are a few exeptions which I still edit to my liking. So there are no materials or textures in the scene that I didn't touch. There are only some models I didn't create, but I checked them all for corrupt structures.

Unfortunately I can't show the scene because it contains furniture designed by my client.

This is how the console looks like when set to 840 minutes (local rendering):
console error screenshot.png
As mentioned before: The moment I delete this material from the scene, maxwell render goes for the next one alphabetically in line. That made me think whether it could be a RAM issue, however, up to this rendering point maxwell only uses 6GB of RAM (of 64GB available).

This is what I get now…
fireflies.png
I mean, what I don't get is the fact that even pack and go doesn't help.

My cinema 4D is actually a vanilla installation, only about 4 weeks old. Don't have access to maxwell studio…
You do not have the required permissions to view the files attached to this post.
#401346
Seems like it is one problem after the other!!! We have all had times like these, but of course it is not pleasant when there are deadlines involved.

On one hand it does sound like one, or several corrupted textures causing an issue, or perhaps a texture that is not RGB...? However if you can get a render going when set to a shorter render time, then it sounds like something completely different . As far as only getting one missing texture at a time, this also happens in SketchUp and is infuriating. Try doing as Mark Bell suggested and substitute the "problem" textures one by one and see if that helps. Alternatively remove all textures and try again.

Fireflies are usually an issue with GPU rendering, but I have had the issue with CPU using HDRs that are perhaps not the best and using materials with reflection 0 values close to 255. In each material with a bright texture, I usually use the RGB clamp to 235 for reflection 0. The image you posted doesn't show what I would call fireflies though, they are too big and coloured rather than pixel sized and bright white. The denoiser in Maxwell has a tick box for fireflies though, so enabling that may help?

Obviously if there has been a C4D plugin update recently, then that could be the cause of all your issues here.
#401347
Another option to try given you have success at the lower time frame is to render to that time, then use Maxwell's Resume Render and repeat again effectively doing a series of shorter back-to-back renders until you achieve the desired SL. I use the standalone Studio so am not familiar with your plugin and what it includes or excludes.
#401348
LivVis wrote:
Mon Apr 04, 2022 3:56 pm


Well, now I have one local render manually stopped at 9h, let it denoise, and now I'm getting square fireflies for the first time with this scene… I'm just about to start screaming and laughing hysterically :cry:
Okay - it's come back to me - back in v2 when NL materials were downloaded off the open library rather than from within MR there were many dud materials that users had created themselves and uploaded. On one interior scene after a lot of render time just when the finer details of materials begin to show, the render produced odd artifacts similar to the fireflies in your scene. The problem was tracked down to a problem material on a floor tile which would only display after something SL18-19, which back 10 years ago meant a lot of render hours before the problem became visible. I would say your issue lies somewhere in a material setting - it may not be a texture but an incorrect setting for that material remembering how Maxwell uses real life values and something that is outside a realistic value will produce an unrealistic render effect. Depending on how may materials you have loaded, it might pay to create a simple scene, say a cube, and apply one material at a time and render to a high SL to see if the fireflies are reproduced. You have to find the needle in the hay stack so may be start with the materials you feel might be more complex and work back to the standard ones....good luck :-)

Hello dear customers, We have just released a new[…]

Hello, That option is meant to load materials tha[…]

Maxwell Render V5 Series

by CDRDA » Wed Jun 29, 2022 9:41 pm The[…]

Fully working plugin for C4D

nope :)