Everything related to the plugin for Photoshop.
By Marc
#395043
Dear reader,

I'm a bit confused about the gamma settings. MR uses 2.2 to convert between spaces, but when opening a render in photoshop it tells me it uses linear adobe rgb colour space that I have to convert to the regular adobe rgb. This cause small colour mismatches. What is the best workflow here to get a predictable result. Thanks in advance for your help

kind regards

Marc
By JDHill
#395045
I am not an authority on this topic, so would ask you to please try either asking in the main (i.e. not plugin-specific) forum, here, or via customer support, from your account on the customer portal (here).
User avatar
By Mihai
#395046
I think you should just look at the colors in PS because the Maxwell UI is not color managed. If you save a 32bit or half float EXR image from Maxwell, it will NOT apply a gamma curve, it will always save a linear image. If you save a 8bit jpg/png or 16bit PNG or TIFF it will apply a gamma curve. In any case, don't judge the colors *too much* inside of the Maxwell Render UI. Try for example changing color space from sRGB to AdobeRGB (and refresh the view if not using Fast ML) - the colors will look faded inside Maxwell but PS will display them correctly.
By Marc
#395047
Thank you both for your reply.
I've got Adobe rgb selected, never work in sRGB.
I imported the mxi in photoshop where the colour changes occurred.
I'll send my question to customer support aswell.
Thanks.

Kind regards Marc
User avatar
By Mihai
#395052
Marc wrote:
Tue Jul 25, 2017 10:33 am
Thank you both for your reply.
I've got Adobe rgb selected, never work in sRGB.
I imported the mxi in photoshop where the colour changes occurred.
I'll send my question to customer support aswell.
Thanks.

Kind regards Marc
Well the display in Maxwell will always be sRGB.....that's why you see the colors differently when you open the AdobeRGB file in PS.
User avatar
By tom
#395066
Color spaces are small volumes -called color gamuts- in the visible color space. Color spaces are there because no hardware can display full gamut. Maxwell, internally renders using full visible gamut and stores it as its native linear wide gamut format called MXI. sRGB color space is default color space as Maxwell UI, most operating systems and common consumer hardware displays in sRGB color space. This means, when Maxwell frame buffer (MXI) is sent to display, it's getting fitted into 8-bit sRGB gamut for the viewport. When you save the viewport in 8 or 16 bit, it will be saved in the selected color space. If you select other color spaces, the Maxwell viewport will not display correct colors while the saved images will still be in right colors. Try making a render and save it as PNG using different color spaces. You will notice the colors will not look OK on Maxwell UI, while these files will all look nearly equal in PS. Because, PS has a color managed display which simulates any profile in your monitor gamut.

In short, you have 2 options in your workflow. You can either use AdobeRGB color space for your renders and they won't look correct in Maxwell viewport but, correct when opened in PS. (Assuming you save 8 or 16 bit JPG, PNG etc, not MXI) or you can save MXI without worrying about gamma or color gamuts, then open it using 32-bit option in PS. If you have AdobeRGB selected in your saved MXI, it will automatically be assigned when you open the image as 8 or 16 bit in PS.

If you are confused or have more questions, just lmk.
By Marc
#395085
Hey Tom,

Thanks for your reply.
My workflow is Adobergb always. I set this in the MR tone mapping. I also use a 16 bit display capable of showing the full gamut of adobe rgb. However, I tend to measure everything to be sure.
The thing I noticed when creating a MR material, let's say a HSB 340/85/85, which is fairly vibrant colour, the render turned out slightly blueish, about 3 to 4 points off the colour set in mxed(after measuring, not visual comparison). Also the saturation and brilliance don't match the exact colour because of the scene they don't.

I did a test. Sphere on a plane with this colour, single plane as a light source from the left.
Environment switched off. Think I found it. In the emitter materials dialog box there's an option to set the colour of the light source in ºKelvin. I assumed by default every emitter is daylight. So I never bothered, but when turned on the colours match much better, spot on. i.e. if you use 6500 degrees as standard daylight.

Thank you all for your thoughts

Kind regards Marc
User avatar
By Mihai
#395086
The Maxwell camera is set to consider 6500K as white light. So it should not make any difference if the color of your emitter is simply set to white, or you adjust the color by Kelvins and set it to 6500K. If there is a difference in color of the light being emitted between these two settings then there's a bug.

But again, don't make any color decisions if viewing your render in Maxwell and you're using a gamut other than sRGB. Open it in PS or any other color managed app to see the true gamut.

Very nice! Good impression of the oily specular on[…]

NVIDIA RTX GPU Cards

Is it just me, or do those interior archviz examp[…]

Dmitriy, it looks like NL has no resources to go a[…]

Rhinoceros 6 support

agreed. at this point for workflow i'd take export[…]