Everything related to the integration for SketchUp.
#394583
On Windows at least, Maxwell V3 and V4 don't like to co-exist in terms of licensing and I was forced to put the V4 licenses in a "v4" subfolder to the usual license folder in

C:\ProgramData\Next Limit\Maxwell\licenses\

I put my SU license inside the maxwell_license.lic file, so this file contains both my V4 node license, and the V4 SU plugin license.

I created an environment variable called MAXWELLV4_LICENSE_PATH with the new path in it, and both MaxwellV4 and StudioV4 pick this up. But in SU, I get the following license error:
Code: Select all
Path [environment]: C:\ProgramData\Next Limit\Maxwell\licenses\v4\maxwell_license.lic [requestLicense (1) failed]
If I simply copy this maxwell_license.lic to the main licenses folder, restart SU, the plugin is now licensed. So as long as it's only in the environment path folder, the plugin won't accept it.

----------------------------------------------------------------

Something related to V3/V4 licensing, maybe you can pass this on: I can't leave this "V4" maxwell_license.lic file in the main licenses folder, because then Maxwell V3 says it's not licensed :P (even though I DO have the "maxwell_suite_floating.lic" license in the same folder, which has valid V3 licenses.

Studio V3 is still licensed fine, but Maxwell V3 gets confused by this "V4" maxwell_license.lic, and stops reading any other lic files in the folder apparently. As soon as I remove the V4 one so I only have the "maxwell_suite_floating" left, then V3 Maxwell gets licensed correctly again....

It was fun finding all this out....the licensing combinations and what worked when. :|
#394585
Could you first please confirm that you are actually using MAXWELL4_LICENSE_PATH and not MAXWELLV4_LICENSE_PATH? I figure this must be the case, as I don't see any other way for the error text you report (from SketchUp) to include the "v4" subdirectory.

Beyond that, I'll just first describe what has been working for me (since the advent of v4). I normally use two floating "suite" licenses, one for v3 and one for v4. Each has a "maxwell" and a "maxwell_node" license, with all four entries having been concatenated in a single "maxwell_suite_floating.lic" file, located in the standard directory, without MAXWELL4_LICENSE_PATH having been defined. I then have a "maxwell_license.lic" file, also in the standard location, which points to "HOST localhost PORT 5053". Using this setup, I am able to run v3 or v4 at will, on my local windows machine, and on osx/linux machines across my network. For reference, the (anonymized) contents of my maxwell_suite_floating.lic file look like this:
Code: Select all
HOST localhost <mac address> 5053
ISV nextlimit  
LICENSE nextlimit maxwell_node 3.0 permanent 11 share=h
  issuer=NEXTLIMIT customer="<name>" contract="<name>"
  <etc>
LICENSE nextlimit maxwell 3.0 permanent 10 share=h issuer=NEXTLIMIT 
  customer="<name>" contract="<name>"
  <etc>
LICENSE nextlimit maxwell_node 4.0 permanent 11 share=h
  issuer=NEXTLIMIT customer="<name>" contract="<name>"
  <etc>
LICENSE nextlimit maxwell 4.0 permanent 10 share=h issuer=NEXTLIMIT 
  customer="<name>" contract="<name>"
  <etc>
I don't have a real clear understanding of what you were trying to set up (i.e. whether you are using floating or node-locked licenses, and for what), but this is what has been working for me with my floating licenses.

That said, I think that you should not put SketchUp-specific license data in a file named "maxwell_license.lic", and should rather leave it named as "maxwell_sketchup.lic" (this should be what the v4 licenseactivator generates for a SketchUp license). This should (if I am guessing correctly) be the reason for the error and failure to license from the plugin; if you look in the other lines of the error report, I am guessing you'll find references to rlm reporting "No license for product" when the plugin requests a "maxwell_sketchup" license. If you change the filename to "maxwell_sketchup.lic" you may find that this no longer occurs, and that you are able to use both the plugin and maxwell, though I cannot be sure; if not, please include more specific information about the licenses you're using, as well as the full text of the licensing error report, instead of just one or two lines.

Beyond these comments, I also just performed some tests using strictly node-locked (demo) licenses. I used the licenseactivator to generate them (maxwell_license.lic was generated for v3 and maxwell_sketchup.lic for v4) , then put them in "v3" and "v4" subdirectories of the standard licenses directory, as you describe. I stopped my rlm_nl service and:
  • Set MAXWELL4_LICENSE_PATH to include a "v4" subdirectory and put the node-locked 4.x demo maxwell_sketchup.lic file in that directory. This license file is successfully used both by the 4.x SketchUp plugin and by Maxwell.
  • Set MAXWELL3_LICENSE_PATH to include a "v3" subdirectory and put the node-locked 3.x demo maxwell_license.lic file in that direcotry. This does not work at all; instead, I must set MAXWELL3_LICENSE_PATH to the full path, including the filename. Then it works for Maxwell, but not the plugin; apparently the 3.x licensing code called by plugins did not check the environment variable. Therefore, the only way appears to be to put the license file in the standard location.
Put together, you should be able to put both the v4 maxwell_sketchup.lic and the v3 maxwell_license.lic files in the standard directory, and run either v3 or v4, whether plugin or Maxwell, without setting either MAXWELL3_LICENSE_PATH or MAXWELL4_LICENSE_PATH. Alternatively, you could leave the v3 maxwell_license.lic file in the standard directory, and put the v4 maxwell_sketchup.lic file in some other directory indicated by MAXWELL4_LICENSE_PATH.

So, that's about what I can think of at this point; please check it out and let me know if/how it helps (or not).
#394591
JDHill wrote:
Tue Jun 13, 2017 7:25 am
Could you first please confirm that you are actually using MAXWELL4_LICENSE_PATH and not MAXWELLV4_LICENSE_PATH? I figure this must be the case, as I don't see any other way for the error text you report (from SketchUp) to include the "v4" subdirectory.
Hi Jeremy, thanks for the detailed answer, yes the env variable is MAXWELL4, I wrote it wrong in my post.

So I figured I should just have a maxwell_sketchup.lic and I will do that, just thought it strange the plugin picks up the maxwell_license.lic (which contains the sketchup license) when it's in the main license folder.

My setup is that I have floating licenses for V3, but node locked licenses for V4. I'm guessing this is part of the problem...

But another big part of the problem is there are so many possible license names, and different components of Maxwell seem to care or not care about which ones they encounter first. So: V4 Studio, V4 Maxwell, V4 MXED, V4 plugins, V4 nodes. Aah! I didn't even mention my V4 node locked node licenses in the previous post, to keep things "simple".

You see, both Maxwell and Studio V4, read the environment variable license path fine, but NOT the node. If I want to run a V4 node locked node, I need to have a maxwell_license.lic (which has the node license info in it), in my main license folder, or my V4 node won't run.

But as I mentioned, if I keep this maxwell_license.lic in my main license folder (and this lic file needs to have the V4 node info), then, V3 Maxwell (not Studio V3 for some reason) says it's not licensed.

I'm a bit wary to try any more combinations. So I will just put SU in its own license and leave it in the main lic folder, and whenever I try to do a V4 network render, I will move my maxwell_license.lic to the main license folder, then delete it when I want to run V3. Maybe it should be a requirement that all license file names for ANY V4 product should have the v4 suffix in it. This possibility that the same lic name can in fact be valid (or not!) for both V3 and V4 is just extremely confusing. Keep the lic files of V3/V4 completely separate, no matter if floating or node locked.
#394601
I set up and tested this scenario:
  • maxwell_license.lic contains "HOST localhost ANY 5053".
  • maxwell_suite_floating.lic contains only my floating "suite" v3 license data.
  • maxwell_sketchup.lic contains a node-locked (demo) v4 Maxwell for SketchUp license.
  • All these .lic files are located in C:\ProgramData\Next Limit\Maxwell\licenses.
  • No special environment variables are defined.
  • rlm_nl is running.
The behavior of applications with this setup is:
  • Maxwell for SketchUp 3x: correctly uses my floating v3 license.
  • Maxwell for SketchUp 4.x: correctly uses the demo SketchUp plugin license.
  • Maxwell Render 3: correctly uses my floating v3 license.
  • Maxwell Render 4: correctly uses the demo SketchUp plugin license.
That said, it looks confusing, because though Maxwell Render 4 uses the demo license, there are lines in the console indicating that it is using the MAXWELL4_LICENSE_PATH, and that it is using the maxwell_license.lic file, neither of which is actually true, since the actual reported license type & name are DEMO MODE and Demo Customer.

That is what happens when starting Maxwell Render 4 by itself; however, starting it from within SketchUp is slightly different, because when a plugin starts Maxwell, it passes an argument indicating the type of license it should use. In this case, there are further lines in the console indicating that the application is using the license specified by the -licensepath command line option, and that it is using the maxwell_sketchup.lic file.

I will see about getting rid of this confusion.

However, regarding node licenses, you are getting far outside my range, but if I use the licenseactivator to activate a demo of the "node" product, it writes a file named "maxwell_node_floating.lic" file. And looking at the webshop, there is only a "floating" option for the "Maxwell Nodes" product. So I'm not sure what you're referring to; perhaps the product range was changed. But as I say, we are far outside my area at this point, and I must recommend that you contact the helpdesk with further questions going in this direction.
#394603
Thanks Jeremy, sorry to take up your time with this, I will contact tech support for the rest of the issues. Just thought to the thing about the V4 SU plugin not wanting to load the maxwell_license.lic when it is in a custom path, but it does load it correctly when in the default lic folder (the error message I've written in the first post).

About the "maxwell_node_floating.lic" that gets created, that sounds right. The problem is with node locked V4 licenses, which I have. I even tried using the license activator and entered the serial of my node locked license, and the activator tells me "this is a floating license but no rlm found etc....".

And if I go to the portal and manually enter the hostid, then download the license file, it is simply named "maxwell_license.lic". Even though it's a node license, and a nodelocked one :P

It's kind of messy...
Texture/finish lost in render.

Nothing?

I answered this question myself in Rhino 6 documen[…]

New developments for Maxwell 5.1

- First one the random color don't work with hdr[…]

Material preview

Yes, I have set Maxwell for Rhino as Current Rende[…]