Everything related to the integration for Rhinoceros.
By kami
#393977
Hi all

I got a non-Maxwell related question...
In some files the blockedit command takes very long (in some files over a minute) until I can edit the block. Also when finishing the blockedit command (even if I cancel it an did not change anything).
This is file related and happens in complex files and then every time, I try to edit a block. But I'm not sure if the amount of blocks is the problem. It can already happen, if I have only 5 different blocks.
I think it has to do with the amount of objects in the scene. As I noticed, it helps a lot if I delete all CAD-drawings from the file and export all objects into a clean file.

Does anybody have had similar experiences?

Cheers
Christoph
By JDHill
#393978
One thought/question: are you referring to the case where an embedded block is edited in place (fully within the current Rhino session), or where a linked block must be opened in a new instance of Rhino, edited, and then updated in the current Rhino session's data, once the new Rhino instance has been closed?
User avatar
By dk2079
#393980
hi,

i know what you are talking about.

We were doing some construction drawings (architecture) last year using rhino 5, handling something like 15 layouts with many A0+ pages and tons of blocks coming from references and another ton I created myself to keep the plans updating in the 2d projection and another version aligned in 3d within the 3d Model.

everything was ok, but at some point it started to get slower and slower.. until I was almost unable to keep up with it.

now I do not have a ready solution, but I started to use Rhino 6 (also because display is faster).. now for some reason I do not know, saving back as Rhino5 from 6 WIP solved the slow block editing in v5.

You have to watch out for some things(especially text objects) might behave a bit strange when saving back as 5.0, but mostly, if you do not touch the objects and only re-save as 5.0 it should be fine.

maybe you wanna give that a try :wink:
By kami
#393982
Hey Jeremy
Yes, I was referring to editing blocks in context (usually I do hide everything except the block before editing it). I also noticed similar behavior with the _showselected command. At the moment I am pretty sure, it has something to do with the amount of object the file has, not depending on how many are shown at the moment.
The integrated CAD drawings are mostly turned off, but they contain a huge amount of lines, hatches, text etc.
Cheers
Christoph

PS: thanks for the rhino6 suggestion. haven't tried rhino6 yet, but I'll give it a try!

On support they tell me that the case was created […]

Part of this is my fault, I know. I accidentally […]

Hey J, Yes, the assistants have not been added ye[…]

Texture/finish lost in render.

Nothing?