Everything related to the integration for Maya.
Hi all,
I experience Maya 2017 update 5 crash when a normal map is applied to an object and can not figure out what is going wrong.
Even if I open a scene file containing a normal map, the object is black in viewport 2.0 open GL legacy (no texture is showed).
I have to go to Hypershade > Texture tab and selecting the map will reload it without crash.
But as soon as I select the object in the scene, Maya crash.
I always uncheck Enable Color Management in Preferences window and in the Attribut Editor set the texture file Color space to Raw.
I use .png files for all my maps

Here is my specs:

Windows 7 64 bits (graphic card up to date)
Maya 2017 update 5 (viewport 2.0 in open GL legacy)
Maxwell for Maya 4.1.3

Is someone have the same trouble or is it related to viewport 2.0 compatibility problems?

Thank for your help

Hello Alex,

I have tried to reproduce it here without much luck. I have to say that I'm testing a new version of the plugin that includes several changes regarding viewport representation for Viewport 2.0 (Core Profile), so probably it's not the best version to try it.
Here normal maps seem to be working fine.

Is there anything special that you are doing?
Have you tried using Legacy Default Viewport instead of Viewport 2.0 in Legacy mode?

Hi Fernando,
Thanks you for your kind reply.
- No, I do nothing special, just using normal map in Global Bump slot.
- Yes, usually I work with Legacy Default Viewport because it doesn't crash in this mode,
but I don't see the effect of the normal map in this default viewport.

That is cool that you are writing a new version of the plugin, I hope that you can
implement XGen.

Good luck, have a nice day.


I did somme more test, because if you can not reproducing the crash, perforce the problem is from my side, and nobody seems having the same worry.

I deleted my Maya user preferences file and open an old scene, It doesn't change anything, the probleme still there.

On the other hand, if I do a brand new scene, virgin from scratch with the new user prefs file and apply a normal map to an object, save, exit Maya, restart maya, open the new scene, it works very well.
I think that all my old scenes are corrupted somwhere for any unknow reason, It's related to Maya user prefs.

Thanks you again to have taken time to test on your machine.

Best wishes,


So, after something like three weeks of evaluation[…]

Fully working plugin for C4D

When you will be working on it please try to keep […]

Let's talk about Maxwell 5.2

Is there any update regarding CPU engine ? Som[…]

Hello, I agree with Jasper ... I still have this […]