Everything related to Maxwell Render and general stuff that doesn't fit in other categories.
#398077
Hello everyone!

I just started using maxwell with archicad after a several year hiatus from using Vray with Rhino.
I'm trying to render an interior scene of an apartment apparently lite only by sunlight.
In order to see the sky outside, I lowered the iso and raised the shutter speed. This leads to a dark interior which I tried to illuminate with artificial hidden light.
To avoid seeing weird shadow from the furniture, I decided to place light planes in front of the windows, to complement sunlight.

My problem is that if I hide these light planes from GI, they don't cast their light, but if I don't hide them, they block the incoming sunlight.
I got the idea from this video , where the panel still adds light when hidden from GI.

Am I doing something wrong? I used this material for my light planes.
Thank you in advance!
#398079
Hello Dominique,

The trick is adding what we call a "ghost" BSDF; that is a BSDF with transmittance full white (255,255,255) and ND=1. This particular state simulates vacuum.
If you add it to the emitter material it won't cast shadows; then you can hide it to camera and you've got an invisible emitter.
Also, in Archicad, if you are using an emitter material, you have the option to "Hide geometry" which does the same thing.


I hope it helps.

Best wishes,
Fernando
#398082
Thank you very much.
I had a hunch it was gonna be something like that.
A friend of mine who works with 3ds and Vray told me there was an option to choses whether an object "occludes other lights" or not, but I guess doing it material side makes sens as well.

I'm gonna try it right now.
Thanks again!

Edit:
It works, I took all the existing BSDF channel out, and added one with the specification you told me. Though I can't seem to find the "hide geometry" I only see "hidden from camera" (it still casts shadows) and "Hidden" (it doesn't cast light nor shadow)
#398085
Hi Dominique,

The "Hide geometry" option I refer to is a property of the emitter material (from the presets), not of the object. Please, check this screenshot:

Hide_geometry_AC.png
I hope this helps.

Cheers!
Fernando
You do not have the required permissions to view the files attached to this post.

Well ... technically GPU on Macs are not really su[…]

Yes and Solidworks!! Wow Blast from the past Nico![…]

FormZ 9 support

One more vote from me! Form Z is the only program […]

GPU high resolution crash

so, the problem is not resolved in V4