Page 1 of 1

Command line noobie needs help

Posted: Tue Apr 19, 2005 12:30 am
by leoA4D
Pity the noobie. :cry:

M~R is resting here dormant with no way into it and that is too much to ask a sane person to endure.

I have tried noseman's and other's command lines and I can't get past the first half of the line, "/Applications/maxwell/mxcl -mxs:....". I've tried variants and time and again, I get a rejection, "No such file or directory". The other half may not work, too.

Help, please!


Posted: Tue Apr 19, 2005 3:58 am
by lluistar
if you installed the latest alpha the path to the mxcl should be /Applications/_3D/ instead of /Applications/maxwell/mxcl

Just try this at first. The terminal will output the launch of the maxwell application and their syntax:
Code: Select all
  MAXWELL RENDER (M~R) version 1_1_33_0001_alpha_ 
  MAXWELL Console Application version 1_0_1_0001_alpha
    (C) 2004 Next Limit Technologies


>> Num processors: 1

SYNTAX: -mxs:name [-animation:A;B-C;D-E(frames) | -a] [-output:path | -o]
        [-res:xRes x yRes | -r] [-time:minutes | -t] [-priority:low | -p:low]
        [-threads:numThreads | -th { 0 for autodetect } ] [-display | -d] 
        [-sampling:sampling level | -s] [-quality:low | -quality:normal | -q]
        [-mxi:write | -mxi:w | -mxi:w,path]
        [-mxi:continue | -mxi:c | -mxi:c,path] [-nowait]
        [-layers:r,a,c,z(min,max) | -l]

Example: -mxs:c:\scene.mxs -res:640x480 -time:10 -th:2 -d -a:3;17-32
         -l:r,z(-0.3, 2.4 ) -o:c:\output.jpg -mxi:w,c:\file.mxi
Terminate it (command + .) nuw press the arrow up key and the last command will apear again complete it with the rest of the info and happy render

Posted: Tue Apr 19, 2005 4:31 pm
by leoA4D
Thanks lluistar. I hope you can stay with me on this.

I downloaded opened M~R per the instructions. When I entered,
/Applications/_3D/, the response was "No such file or directory".

I don't recognize the _3D in the path to the mxcl. I tried dropping it and the terminal response was "Illegal Command".

Ready to try new ideas.


Posted: Tue Apr 19, 2005 6:45 pm
by Matthew Schrock

If you download the latest version you will have file named "maxwell.dmg"

Double-clicking the .dmg file will mount a virtual disk. On this virtual disk you will find a file named "Readme first". This file contains step-by-step instructions for installation, setting up the license file, and running from the command line.

It sounds like your environment variables are not set properly - you can check this by typing "env" at the command line. You will get a list of environment variables, but the one you are looking for is:


This environment variable is being set by the environment.plist file that NL includes with the download.

While there are other ways of setting environment variables I would recommend that you use the environment.plist file - that way the variable is set as soon as you log in without even starting the terminal. This means that the variables are already set even when Maxwell is launched from the Finder.

Hope this helps...


Posted: Tue Apr 19, 2005 8:07 pm
by leoA4D
Thanks for the help Matthew.

I followed the installation instructions carefully.

Per your instructions, I successfully found MAXWELL_ROOT=/Applications/ in the environmental variables list after entering "env". This is a major success for me!

From the M~R, ReadMe First doc, I tried: $MAXWELL_ROOT/mxcl
prints all the command line options available. The Terminal returned "Illegal instruction".

Applications/ seems to be the path to MacOS; no problemo. The folder I want to open is noseman's (thanks!) file focus.mxi which is on my Desktop. You can see what this earned me: /Applications/ -mxs:/Desktop/focus.mxs -d -mxi:w,/maxwellfolder/focus.mxi -res:640x480 -s:10
Illegal instruction.

Your help is welcomed.


Posted: Wed Apr 20, 2005 7:24 am
by lluistar
Sorry Leo,

_3D is a folder inside Applications where I keep all 3D related applications together. This is the right path /Applications/

Your command is also not correct /Applications/ -mxs:/Desktop/focus.mxs -d -mxi:w,/maxwellfolder/focus.mxi -res:640x480 -s:10 Try this one /Applications/ -mxs:~/Desktop/focus.mxs -d -res:640x480 -s:10 -o:~/Desktop/focus.tga

"~" is the shortcut for /Users/your-user-name/

if you are unsure of how to write a path to a file or a folder in the terminal, just drag and drop that folder or file on the terminal window and you'll get the correct path.

Your $MAXWELL_ROOT/mxcl Terminal return indicates that your enviromental variable is not correct. Did you log out or restart your computer after setting the variable. Because if you haven't the variable hasn't been aknoledged by the system, and then it does not work.

Posted: Wed Apr 20, 2005 3:45 pm
by leoA4D
lluistar, thanks for hanging in there with me. This is a bit thick for me but, I'm enjoying it.

Your excellent tip about dropping the file on the Terminal worked to confirm the path. I reinstalled M~R to be certain to restart after setting the variable. Still no render, no joy. This is the command line:

/Applications/ -mxs:/Users/your-user-name/Desktop/focus.mxs -d -res:640x480 -s:10 -o:/Users/your-user-name/Desktop/focus.tga

The Terminal returned "Illegal instruction".

I tried $MAXWELL_ROOT/mxcl again and got the "Illegal instruction". When I entered env, MAXWELL_ROOT=/Applications/ is there.



Posted: Wed Apr 20, 2005 4:08 pm
by mr_render

A few of us have had the same problem. See the "Bug reports" forum and the thread "Maxwell OSX won't start". No solution yet :(

Posted: Wed Apr 20, 2005 4:37 pm
by leoA4D

Thanks for the heads up. It sounds familiar. It may not make any difference but, I'm not dual.

Since Terminal is new to me, I'm going to wait to see if someone confirms that my Terminal inputs are ok before adding to the Bug list.

I will keep a finger in the bugs page from now on.


Posted: Wed Apr 20, 2005 6:50 pm
by Matthew Schrock

Your command line input seems to be fine - I copied your command line and it executed without a problem on the dual G5.

It looks like it may be a problem that is specific to the G4 processor - when I try to run it on the G4 powerbook I get an "illegal instruction.


Posted: Wed Apr 20, 2005 7:46 pm
by leoA4D
Matthew, that's it. For me, it to the Bug Reports and join the queue.

Thanks for the G4/G5 sleuthing.