Everything related to Maxwell Render and general stuff that doesn't fit in other categories.
By lluistar
#11948
I just downloaded Maxwell for Mac OS X.

There is no plug-in for mac, So very little oportunity to test.
There is not especific documentation for Mac, only Linux.

Maxwell come in an .app package, when it is basicaly a binary. Also all the documentation is inside the package.

Usualy Mac users never look into the application packages. Well... some do :oops:

Disclaimer: This is the way I installed Maxwell. Sure, that it might not work with the plugins. But since there is not specific Mac OS X installation info. I had to inprovise. Do it at your own risk.

Reading the documentation, says that a MAXWELL_ROOT enviroment variable and a Path have to be set.

1- I moved the folder MacOS out of the package and renamed it Maxwell I placed it into the Applications folder.

2- To set the enviroment variable I installed a preferences panel called Environment Variables it's a free app from Rubicode.
http://www.rubicode.com/Software/RCEnvironment/

variable: MAXWELL_ROOT
value: /Applications/Maxwell

Image

Now you need to Log out and Log in again.

3- Now you need to install the licence.
create a file called license.txt with the information Next Limit sent you and place it inside the folder Maxwell

4- Now you should set the path to the Maxwell folder. :oops: I haven't done it. I just went directly to step 5.

5- Currently I can't create any mxs since I have no access to any windows. So, I used the file caca.mxs that come with the package. I copied this file to the Desktop. and wrote in the terminal

$ /Applications/Maxwell/mxcl -mxs:/Users/lluistar/Desktop/caca.mxs -d

and voala!!!!

Image
Image
First Mac OS X Maxwell render in the forum.

The scene looks familiar. Is it Tom's?

I would love is some one can mail me or post any .mxs file to test.



Salut

Lluis
Last edited by lluistar on Fri Mar 25, 2005 9:45 am, edited 1 time in total.
User avatar
By noseman
#11958
will do this ASAP!
Thanx a million Lluis!
User avatar
By mgroeteke
#12032
lluis, no chance with your installation method here... i follwed exactly your steps and i put the license.txt into the maxwell folder. now the app runs, but the maxwell app does not find the license... :?

please, nextlimit, can you give us OSX users a working installer soon??

markus
User avatar
By N&B
#12039
strange...it worked like a charm for me.
Which application did you use to create the license.txt file?
User avatar
By N&B
#12053
I created it with simple text (under classic).
I had the same issue, but it was because I named my maxwell folder "Maxwell∂ 1.1.30" and it produces strange characters once displayed in the terminal. I renamed it "Maxwell", end of problems...
By lluistar
#12058
Markus,

Actually your Maxwell is working, and it can't just find a license.

For thr license to work I think it is very important to writte in the license file just what it needs, or it will fail.

Make a search in this forum about the license.

Salut,
Lluis
User avatar
By mgroeteke
#12108
hmm for the license.txt i followed the instructions in the registration email... my folder is 'Maxwell' in applications. there should not be any path issues - you can even drag the file to terminal to get sure to have the right path argument. no idea what's wrong...

oh well, i don't want to loose more time to 'hack' around for just rendering out a demo file and will wait for a proper installer! in the end, it's an early alpha, so maybe there's no more to expect at this stage... the fun will begin definitely when the OSX plugins are available :wink:
By tokiop
#12109
I'm having a "Backup Error - Can not write backup ~/.MacOSX/environment~.plist. Please correct and attempt again." with environment variable...

is there a trick? Is it possible to change the file manually?

i guess i'll have to wait a few days more! :)
By lluistar
#12131
tokiop,

Download this file http://www.wetpaintdsgn.com/docs/environment.plist.zip

unzip the file in your desktop

This file asumes that your path to the Maxwell folder is /Applications/Maxwell if you have it in any other location edit the file with textedit

In the terminal type to create the directory where the enviroment variable should be stored:

$ mkdir ~/.MacOSX

$ cp environment.plist ~/.MacOSX/environment.plist

Now quit all aplications, Log out and Log in.

It should be working then.

Salut,
Lluis
By thomas lacroix
#12135
it's a damn pain in the ... to have to run it manually...
i'll wait for the C4D plug...
User avatar
By tom
#12148
:lol: :lol: heheh... great!
i infected everywhere :lol: :lol:
User avatar
By Kabe
#20613
Well, in my case (OS X 10.3.9) it was necessary to add a "/" at the end of the path. The whole path stuff should a bit more robust IMO. Well, it's an alphs ;-)

Hope it helps

Kabe
By lluistar
#20614
Jack,

Are you using a G4? because if you are. There was a bug. You might try to search the forum for an answer then.

If you are on a G5 you should recheck what you have done and post more information just a *when I run the mxcl command, I get an "illegal instruction"* does not help much to have an idea of what could be wrong.

Salut,

Lluis


Edited: Jack, I've just seen your post on the Mac G4/M~R Alpha 1.033 fix thread. I believe that this is your problem as all G4 owners where reporting the same illegal instruction I don't know how it was solved since i'm on a G5.
Bubbles in glass

Anyone know how to achieve bubbles in glass, ice […]

Denoiser crashes rendering

This is my 1st attempt at using Denoiser. When I […]

ilgioma on Gumroad

Hi everybody, I would like to let you know that fr[…]

MXM - Anodized Aluminium

Those look great! Good job! Thanks Tim :D L[…]