Hey. It's thankfully been a while since I've needed to post in here, but one thing that's popped up a few times is the fact I can't see materials applied to objects that have been patterned or mirrored in SolidWorks, and I was wondering if there was a way to remedy this. It can make things difficult when trying to get an overview of a scene and seeing what still needs materials or not. Here's a screenshot of what I mean...


As you can see, the grid (window frame) has had a green material applied to it which shows up fine. The two and a bit window frames directly to the right - which are seperate bodies but generated by using the linear pattern feature - have also had the same material applied but you can't see it. If I select the objects in the list the materials are applied and when I hit render they do show up (I believe). They're just not showing in SolidWorks... Is there any way to have them appear?

I'm using SolidWorks 2008 with the Maxwell 1.7 plugin on Windows XP 64-bit OS.

Any help would be great. Thanks.
This scenario seems to be working fine here for me on SW2009 & SW2010, but unfortunately I don't have SW2008 installed anymore. It looks like you don't have SW's RealView enabled, so that shouldn't be a problem; what happens if you use the 'Refresh Viewport Materials' button at the top of the plugin's Database Manager window?
Yes, the simpler the file, the better. What I would need would be a file in precisely the state where things are misbehaving, so in this case that would a file where:

- you have a body repeated by linear pattern
- material has been assigned to each copy
- material display is incorrect

Now, as I am writing this, I see you edited your post -- I guess it's not easily reproducible with a new, simpler file? If this file is too big for email, you could use megaupload or rapidshare.
I tried to recreate this issue from scratch with a simpler model, but applying the materials to the bodies actually seemed to work fine that time (always the way). I've had this issue a few times but I can't seem to get it going from anything new at the moment so I thought I'd zip up the model in question.

It's not a huge file, about 35mb or so. Just sent a PM with the download link and some extra details.

Thanks for taking a look.
The basic problem is that while you are assigning your Maxwell materials at the body level, many of the faces of those bodies already have a SolidWorks material assigned. So, to see the body-level assignments, you need to remove the face-level assignments, since face-assignments override body- and feature-level assignments in SW.

The quickest way to get things sorted would be:

1. select the top node in the Feature Manager tree
2. edit its appearance
3. in the SW material editor, click Remove Appearance
4. then, click Remove All Appearances
5. go get a cup of coffee
6. accept the changes and rebuild the document

That will get rid of all your SW colors and prepare the model for the plugin to show you its materials without them being obscured by higher-precedence SW material assignments -- using the plugin's Refresh Viewport Materials command should now get you your desired result.
So I had time to try this technique this morning and it hasn't worked. Maybe worth noting that when I clicked Remove Appearance then Remove All Appearances, it loaded very quickly. It sounded as if this step perhaps should've taken a while to fully remove everything? I hit rebuild anyway then refreshed the viewport materials through the plugin and it's stayed the same.

Just to be sure I'm not editing the wrong thing, it should be this node, right?

You're editing the right thing, but apparently SW's behavior is different in SW2008. Those steps work fine for me with this model in SW2009 and SW2010 -- when I click Remove All Appearances, SolidWorks takes about a minute to process the command, but afterward, all materials are indeed purged. However, the whole concept of materials was very much in flux in SW2008, so I cannot say whether you might need to use some other strategy in that version.

Basically, if you try those steps and it doesn't seem to work, just turn on the face selection filter and select some face -- confirm whether or not it still has a SW material assigned to it. Because if it does, then that material is going to take precedence over any body material you may have assigned. One way or another, the face material has to be removed, so try removing it directly from the face, then move on up to the face's parent and see if you can remove all of its face materials in one shot, and so on...apparently it's not working for you at the top part-level, but somewhere along the hierarchy it will.
MXM Library

Just seems when I look at material sharing/discus[…]

How to get material's color and texture info

ok, thank you Harvey.

You could make the ceiling plane you have an emitt[…]

Maya plug-in MR 5.2

Ou la la.. we need an Update of Maya Plugin Next L[…]