#380225
Hi, I had Maxwell plugin 3.0100 (and previous version before that) installed in 701 and was not quite aware that it defaulted to adding Maxwell specific objects to all scenes I opened after the plugin was installed.

I just upgraded to Modo 801 (without installing any Maxwell plugin) and could not open any of the 701 scenes that had auto-added Maxwell objects.
Modo 801 just chokes upon finding these unknown objects and hangs indefinitely.

I then found and tried the "Remove Maxwell properties from scene items" and used that in the plugin window in 701.

This seemed to work as the 701 scene loaded without problems in 801.

However when hitting F8 (preview render) or F9 (render) in 801 it still finds unknown "maxwell.object" I select "Yes to all" to skip this and then it finds "maxwell.camera" and again I select "Yes to all" to skip but then 801 just hangs.

SO, it seems to me that your plugin needs to be updated to really remove ALL maxwell.xxxx objects so that I can load my 701 scenes into 801.

I am not interested in installing the Maxwell (beta) plugin in 801 until this is fixed as essentially I then become dependent on having the Maxwell plugin installed always because the plugin has added special objects that make the file format in essence very proprietary and no longer compliant with standard Modo.

Hope this can be fixed rather quickly
#380229
Hello,

I will check what I can do on the plugin side, but it is more likely a modo bug if the removal was not perfect.

But the problem is really not so big as you think it is. After modo shows the missing ..... warning messages you can resave the scene and it clears all the not found Maxwell settings.

By the way in the plugin Preferences dialog > Workflow tab you can switch off "Automatically add Maxwell packages" flag, so plugin won't add the Maxwell settings to the objects automatically.

Edit: Sorry now I see that I misunderstood your message. So modo 801 hangs on it? What happens if you open the scene in modo 701 after you turned off the Maxwell package. Do you have the missing (or unknown) .... messages? Can you clear these out under modo 701?

Márton
#380276
Hi, yes 801 hangs unfortunately.

701 without the maxwell render plugin I have not tried.

Of course it can be viewed as a kind of bug that Modo is not able to skip the hidden maxwell objects, but I do not expect Modo developers to have this at the top of their priority list...

Can try installing 701 on another PC and open some scenes where I have chosen to remove maxwell objects.

Yes, I am aware about the workflow setting now, but too late for the scenes I already opened with the auto-add option active.
#380282
If it is a modo bug than it is a serious one.

Just imagine every modo plugin stores plugin related information somehow and it means the plugin should create its own modo items.

So in case modo can't delete item for a missing plugin, it is an issue for every modo plugin!


I have tried to replicate the situation here, but was not able to crash modo.

Maybe something scene related? Do you have this problem with every modo701 scene?

Is there a chance to check your scene?


Márton
#380284
Mystery sorted out... partially my own mistake I guess... :oops:

The situation was that I had used some proxy objects in my scene. Proxy objects are essentially references to objects in other Modo files.
From the main scene file you also have the option to open the proxy object file - and this is when Maxwell objects have been auto-added.

So solution was to open every Modo file that my proxy objects referenced in 701 and select to remove all Maxwell objects.

Proxy objects are not loaded until rendertime, so that should have given me a clue earlier, because the main file loaded without errors but then errors occurred when I hit render...

Still, yes, Modo should be able to just skip these objects since it presents a dialog to that effect, but then hangs instead.

Anyway there was a logical solution, and the Maxwell plugin function to remove Maxwell properties actually works (but is not recursive into referenced files...)
#380288
Hello,

Thanks for analyzing the problem.

I will discuss it with he modo guys and hopefully we can find a solution (on the modo or plugin side).


Edit: after doing some own test.... it seems there is a bug in proxy item handling. Here I can crash modo with a single proxy item without Maxwell plugin stuff.

Márton
Maxwell for Rhino on Max missing Toolbar

Hello, For some reason, the Mac version of Rhino[…]

Let's talk about Maxwell 5.2

Price for sure matter a loot. Speed is the core i[…]

hardware question :)

1) give us a budget limit 2) write down what hard[…]

Materials translucent with V5.1

Well, the problems can be in the chair, the monito[…]