By fountainhead
#393772
Maxwell 3.2.1.2, and Maxwell for SketchUp 3.2.5. I am trying to export one object only, a half dome, made of quads, 960 faces, with spherical UV mapping applied, tried both SketchUV plugin, and Quad Face Tools plugin, result is the same. Export is extremely slow, when opening in Maxwell Studio, there are 960 versions of the same material created, one for each face in the half sphere, there are also 960 triangle groups created, and 1 UV set. If I delete all of the materials and triangle groups, unlock the 1 UV set and apply spherical mapping in Studio, I can adjust the UV's to suit and apply one material with no triangle groups and all is well, so not stuck, just confused as to why the export works like this? Shouldn't the exported custom UV's from SketchUp tell the one material where and how to be applied on the collective faces on the sphere, instead of exporting each individual face as a triangle group, with an associated custom version of the material (basically that bit of the material that is applied to the associated face)? Something doesn't seem right.
By JDHill
#393784
This is the reason for the existence of the context menu > Maxwell > UV Coordinates > Ignore Distortion option. If you enable that (the geometry must be in a group or component), you will see the actual UVs. The reason for the per-face materials you see otherwise is that SketchUp uses a texture custom-distorted for each face, and since each face needs its own texture, it follows that each needs its own material. It may be an option to use context menu > Maxwell > UV Coordinates > Spherical, by which SketchUp UVs will be ignored, and spherical ones generated instead, by code in the Maxwell SDK.
Texture/finish lost in render.

Nothing?

I answered this question myself in Rhino 6 documen[…]

New developments for Maxwell 5.1

- First one the random color don't work with hdr[…]

Material preview

Yes, I have set Maxwell for Rhino as Current Rende[…]