By Wynott
#382007
Can't get displacement maps to fit surfaces. The scaling is messed up, i.e. the texture is much bigger than the surface. In other words only a portion of the displacement map is showing on the surface.

I am probably doing something stupid but have been experimenting for hours and am not getting anywhere.

Screenshot attached.

Image
By JDHill
#382008
What does the mapping look like, if you set the viewport to Rendered mode? There is nothing special about mapping displacement, as compared to any other texture, so my guess would be that either a) there is a custom mapping applied to the surface, or b) at some point, the texture had real scale (i.e. Units > Meters, instead of Relative) enabled, which caused a cubic UVs to be generated and applied. In either case, you should be able to apply a Surface mapping, in order to fit UV space to the surface.
By Wynott
#382011
Hrmm.... The surface was already shrunk. I added a surface map on channel 1, changed the channel of the displacement map to 1. Still no joy.

There must have been something weird going on with that surface specifically. I remade a new surface based on the edges of that one and it's working.

It looks more like a smooth normal problem. Like i[…]

I had some very strong highlights in some material[…]

Daydreamer

Thanks everyone! I didn't want to use volumetrics […]

opening V5 files in v6

just installed latest version for Rhino V6 when I[…]