By kami
#376560
Hi Jeremy

I got a license error inside of rhino (I cannot export the MXS).
Maxwell Render itself and the render node is working fine. Even reinstalling did not help.
What can I do to fix this?

Cheers,
Christoph
By JDHill
#376561
What (pertaining to the license) is printed in the Rhino command line, and/or the Log Viewer? I don't know much about the licensing, but do you need to have your firewall opened to Rhino? I guess the first thing I'd try is fully disabling the firewall, only for a minute, just to check if it makes a difference.
By kami
#376566
This is the error message:
Code: Select all
********************************
* Maxwell for Rhino
* Version: 3.0.0.0
********************************
* Session Log
* Date:  14.01.2014
* Time:  10:58:34.7262581
* File:  C:\Users\User\AppData\Roaming\MaxwellDotNET\Plugins\Rhino\Logs\session_log_10_58_34____1_14_2014.txt
********************************
* line 1: OnLoadPlugIn, Running on Rhinoceros 5.0 x64.
* line 2: OnLoadPlugIn, Checking required paths...
* line 3: CheckRequiredPaths, Maxwell 3 directory found  at 'C:\Program Files\Next Limit\Maxwell 3'.
* line 4: CheckRequiredPaths, maxwell.exe found  at 'C:\Program Files\Next Limit\Maxwell 3\maxwell.exe'.
* line 5: CheckRequiredPaths, studio.exe found at 'C:\Program Files\Next Limit\Maxwell 3\studio.exe'.
* line 6: CheckRequiredPaths, mxed.exe found at 'C:\Program Files\Next Limit\Maxwell 3\mxed.exe'.
* line 7: OnServerMessage, initializing Maxwell Database, using directory: C:\Users\User\AppData\Roaming\MaxwellDotNET\SDK\DB
* line 8: OnServerMessage, to learn about using alternate database locations, see C:\Users\User\AppData\Roaming\MaxwellDotNET\SDK\Config\readme.txt
* line 9: OnLoadPlugIn, Creating DropTarget
* line 10: OnLoadPlugIn, Retreiving user-preferences
* line 11: OnLoadPlugIn, Read prefs from 'C:\Users\User\AppData\Roaming\MaxwellDotNET\Plugins\Rhino\Defaults\UserPrefs.Rhino5.xml'.
* line 12: OnLoadPlugIn, Starting version-check thread
* line 13: OnLoadPlugIn, Starting plugin-update thread
* line 14: OnLoadPlugIn, Enabling Scene events
* line 15: OnLoadPlugIn, Synchronizing cameras...
* line 16: SynchronizeCamera, Created camera 'Perspective'.
* line 17: OnLoadPlugIn, Plugin-load finished successfully.
* line 18: ShowWindow, sz=700x392h, loc=400,328(virtual), pWnd=393848
* line 19: Maxwell_Render, Maxwell_RenderRegion (RenderScene)
* line 20: SynchronizeCamera, Created camera 'Perspective'.
* line 21: Maxwell_Render, Maxwell_Render (RenderScene)
* line 22: IsLicenseValid, Checking license...
* line 23: IsLicenseValid, Licensing failed:
 - Product: "maxwell"
 - License: C:\ProgramData/Next Limit/Maxwell/licenses/maxwell_license.lic
 - Initializing using path...
 - Requesting "maxwell" license...
 - Request failed.
 - Unable to obtain a valid license:
     Request Status: -22 [No error]
     Manager Status: No error
     License Status: No heartbeat response received (-21)
* line 24: IsLicenseValid, No valid license found.
* line 25: CheckForUpdate, Checking for plugin updates...
The License File "C:\ProgramData/Next Limit/Maxwell/licenses/maxwell_license.lic" exists and contains the name of our license server. And the Maxwell Render window works fine, as well as the Render Node.
Only the plugin cannot export the MXS. This is btw, the only computer with this problem. And it was running fine at one point. The Firewall is completely disabled. A restart did not help either.
By JDHill
#376573
Thanks, I will have to ask someone who knows about the licensing, what might be the meaning of that message. In the meantime, please read the licensing troubleshooting, to see if you can find anything that might seem relevant to this scenario.
By kami
#376577
Thanks.
I don't even know what I can try, because the Maxwell Engine itself runs fine. I even reinstalled the rhino plugin, but that didn't change anything.
User avatar
By polynurb
#376625
You also disabeled FW on rlm server?

Just asking cause i had issues with the port suddenly changing on the rlm recieve side just recently
By JDHill
#376632
Hmm, but if it were that, then Maxwell shouldn't work either, since both the plugin and Maxwell should be using the same port, as specified in the license file on this machine. I guess one person reported that disabling IPv6 on his network adapter helped, though I don't much see the sense in that.
User avatar
By polynurb
#376639
JDHill wrote:Hmm, but if it were that, then Maxwell shouldn't work either, since both the plugin and Maxwell should be using the same port, as specified in the license file on this machine. I guess one person reported that disabling IPv6 on his network adapter helped, though I don't much see the sense in that.
They don't, at least studio and maxwell standalone use different ports.

Eg i had studio fail and maxwell gui working
By JDHill
#376641
I'm trying to figure out how that could happen. Above, the plugin is obtaining the path to the license file successfully, so it will try to initialize the licensing using that path. If the license file were not found, though, the system would fall back to using a "broadcast" method, the details of which I do not know, so perhaps it is by that method that you get different ports being used by different applications. It would be interesting, then, to find out what happens, when you run into this, what happens if you remove the license file, because it may be that I could alter the logic to help things run smoother.
User avatar
By polynurb
#376642
my last post was from the subway.. so i think i need to correct some of what i mentioned being back at the source:
#Version: 1.5
#Software: Microsoft Windows Firewall
#Time Format: Local
#Fields: date time action protocol src-ip dst-ip src-port dst-port size tcpflags tcpsyn tcpack tcpwin icmptype icmpcode info path


2013-12-06 00:24:18 DROP TCP ***.***.***.22 ***.***.***.11 55903 63098 48 S 1629031669 0 8192 - - - RECEIVE
2013-12-28 01:47:13 DROP TCP ***.***.***.22 ***.***.***.11 65314 49166 52 S 2126462788 0 8192 - - - RECEIVE
2014-01-15 00:19:01 DROP TCP ***.***.***.30 ***.***.***.11 41747 49166 48 S 624425396 0 8192 - - - RECEIVE
.22 is my local workstation at the office, .30 is my laptop, .11 RLM server (win 2012 essentials server). don't bother the different subnets it is routed correctly via ipsec site to site connection.(laptop from home)

so 1st: the source ports are changing.. ok should not be a problem on a standard node/workstation where outbound rules are not set automatically, at least in a standard windows config w/o custom firewall installed.
but as i mentioned in this post, rlm tries to listen to a not documented port, after i opened that one i was able to license maxwell ok.
now look what happens dez 06-dez 28 destination port changed as well!

so RLM should better be set to allow listen on all ports.

I can't proof my statement that studio needed a different destination port than maxwell gui, as checking now both are trying on 49166, but i believe to remember i had to change something inbound on the .11 machine to get it to license correctly.
Last edited by polynurb on Wed Jan 15, 2014 1:32 pm, edited 1 time in total.
By kami
#376645
my rhino is working fine now too. I have still no idea what happened, but sine it is working now, I'm hoping that it'll stay like that.
But I have only one idea what could have helped. I did restart the machine in question, which did not help. But since there was a power crash, the server had to be restarted as well and I'm guessing that this fixed the issue.

PS: I am still running my server without a firewall, since I was not able to put in the right firewall rules. Which port do you have to put in there? not only 5053?
User avatar
By polynurb
#376652
RLM inbound rule on lic server:
Image
choose rlm
Image
set the ports: here 5053 won't do it, at least with the initial installer, so i am running this with ALL TCP ports atm.
that is NOT best practice however, it depends on the general layout of the network(HW perimeter firewall?) and RLM vulnerability, but it should potentially be never opened to the WAN side of your network! so the scope is very important
Image
set the ip adresses/networks here from which you want requests to be allowed:
check if your nodes are on different subnets! add them here...
Image

Image
By kami
#376673
thank you very much. I'll try that!

The problem with rhino not being able to export the MXS just happened again on a diffent computer. This time, restarting the computer and the license server computer fixed it.
Maybe this is narrowing it down? My only idea at the moment would be, that we don't have enough licenses for all computers. We have 12 computers and only 10 licenses. But not all computers are using Maxwell at the moment. Not sure how the software works to check in/check out licenses. Or if just opening rhino and modelling already blocks a license.
I tried to ask the support where you can check how many licenses are in use, but did not get a response.

But since Maxwell is still working fine if you start an older MXS, that does not really make sense either. And I would think that the error message would show if there are not enough licenses.
By JDHill
#376675
Did you check the RLM License Server topic? You access the server console by pointing your browser at localhost:5054. If you click on Status, then on the "nextlimit" button under "Server Status" in the lower table, you can see which licenses you have, how many are checked out, etc.

The plugin does not request a license until you actually try to export an MXS file, and it requests that the license be released when you close Rhino.

It looks more like a smooth normal problem. Like i[…]

I had some very strong highlights in some material[…]

Daydreamer

Thanks everyone! I didn't want to use volumetrics […]

opening V5 files in v6

just installed latest version for Rhino V6 when I[…]