Particles and object motion blur, crash

Post Reply
Marc
Posts: 13
Joined: Thu Jan 08, 2015 7:17 pm
Which 3D software do you use with Maxwell?: Cinema4D

Particles and object motion blur, crash

Post by Marc » Wed Apr 27, 2016 10:42 am

Hello,

I'm trying to create a heavy rainfall with the use of a particle emitter. (sphere with low poly's (12) However when I turn on object motion blur (value 3) in the scene properties panel, c4d crashes when hitting fire or the render button (R), when I use more then about 500 particles. Without the object motion blur there isn't any problem and I can add 10.000 particles easily. I must be doing something wrong, but I can't figure out what. I tried to switch off the "standard" motion blur in the scene properties as well as the motion blur in the C4D prefs (under physical tab). All to no avail. It looks like a lot of particles with object motion blur is a problem?

I use the latest MacOs, C4D (R17) and MR plugin

Cheers
Marc

JDHill
Posts: 9496
Joined: Wed Nov 16, 2005 3:02 am
Which 3D software do you use with Maxwell?: Rhino
Location: desk #861

Re: Particles and object motion blur, crash

Post by JDHill » Wed Apr 27, 2016 11:53 am

Does it literally crash, or just appear to be hanging up? If I understand what you're doing, it seems likely to be the latter, and I would suggest, rather than emitting physical spheres, of which the positions of each must be recorded in order to support motion blur, that you instead remove the sphere from under the emitter, and add a Maxwell Particles tag to the emitter instead. The tag internally supports motion blur irrespective of whether it is enabled for the scene in general, and if you don't want the perfect spheres it produces by default, you can link an arbitrary object in its Clone feature.

If that's not it, please upload (to dropbox or similar) a simple scene that reproduces the problem, because in trying to do it using your instructions, I've yet to produce a crash (though as I indicate, I can indeed bring the machine to its knees by trying to export motion blur for thousands of physical objects being created by an emitter).
Next Limit Team

Marc
Posts: 13
Joined: Thu Jan 08, 2015 7:17 pm
Which 3D software do you use with Maxwell?: Cinema4D

Re: Particles and object motion blur, crash

Post by Marc » Wed Apr 27, 2016 3:45 pm

Hello JD,

I left C4D for about 15 minutes (spinning ball) but nothing happens.
I thought already that I asked too much of the computer/software.
The Maxwell particle tag works well on an emitter object however, if
I want to get rid of the perfect spheres, I used a clone object where I
want to add some displacement to, but that gives me a crash. Bump is
fine, so I probably have to go that way.
I have one more question, the amount of motion blur depends on the
speed of the particles, set in the emitter properties box in combination
with the shutterspeed set in the scene properties box, is that correct?
Thanks for helping me out JD.

kind regards

Marc

JDHill
Posts: 9496
Joined: Wed Nov 16, 2005 3:02 am
Which 3D software do you use with Maxwell?: Rhino
Location: desk #861

Re: Particles and object motion blur, crash

Post by JDHill » Wed Apr 27, 2016 4:29 pm

Thanks, yes that is not a crash, and it will be much better to use the Maxwell Particles tag. I don't observe any crash when applying a displacement material, so would appreciate seeing an example scene for that.

Regarding the blur vs camera shutter, yes, that is correct; when exporting the object (a MaxwellParticles extension, or a MaxwellCloner modifier on the cloned object), the plugin specifies the shutter speed for the current camera (whether using the value from Scene Object > Default Exposure, or one from a Maxwell Camera tag), which is used by the extension to calculate blur, based on the velocity of the particles, and the motion blur strength specified in the Maxwell Particles tag.
Next Limit Team

Marc
Posts: 13
Joined: Thu Jan 08, 2015 7:17 pm
Which 3D software do you use with Maxwell?: Cinema4D

Re: Particles and object motion blur, crash

Post by Marc » Wed Apr 27, 2016 4:55 pm

Thanks very much JD!

For the material, I did a very simple water. ND 1.33, transmittence V=90% white, roughness 1, attenuation 1m, and I loaded the gray noise image (texture folder) that comes with maxwell in the "map" of the displacement. Left the displacement values as they are.
The material is added to a low poly sphere that is the cloner object.
Does this clarify it enough? Otherwise I'll sent you a scene tomorrow.

Kind regards marc

JDHill
Posts: 9496
Joined: Wed Nov 16, 2005 3:02 am
Which 3D software do you use with Maxwell?: Rhino
Location: desk #861

Re: Particles and object motion blur, crash

Post by JDHill » Wed Apr 27, 2016 5:07 pm

Yes, please send it, as I'm still not seeing a problem, there must be some missing detail.
Next Limit Team

Marc
Posts: 13
Joined: Thu Jan 08, 2015 7:17 pm
Which 3D software do you use with Maxwell?: Cinema4D

Re: Particles and object motion blur, crash

Post by Marc » Thu Apr 28, 2016 4:36 pm

Hallo JD,

I'm sorry I'm not able to reproduce the crash with displacement.
If I come up with something I'll let you know.
Thanks very much for helping me out.

Kind regards

Marc

Post Reply

Return to “Maxwell for Cinema 4D”