#388619
Hi

When I installed 3.2.0 tonight, my Cinema R17 won't launch anymore. I'm on Yosemite. By install, I mean I put the entire folder in the Zip here: /Users/bjorn/Library/Preferences/MAXON/CINEMA 4D R17_89538A46

REgards

- Björn
Last edited by bjorn.syse on Wed Oct 07, 2015 10:04 pm, edited 1 time in total.
#388622
The plugin must be installed in Cinema's plugins directory; for example (since it may be slightly different on your machine):
Code: Select all
Applications/MAXON/CINEMA 4D R17/plugins/Maxwell_for_Cinema_4D-3.2.0-R14-R17
Cinema uses a plugin's folder name to generate its item in the Cinema plugins menu, so you may prefer to shorten it from "Maxwell_for_Cinema_4D-3.2.0-R14-R17" to just "Maxwell". Personally, I end up with lots of plugin .zip files in the plugins folder, so that if I want to switch versions, it is just a matter of deleting whichever one is current (without Cinema running, of course), and unzipping the one I want to run.
#388630
I am a bit confused, because you say you "did install it in the plugins folder", and then that you get the same error if you "try the plugins folder in the /Applications structure," which sounds like you've tried two different places. Either way, you should make sure it has been deleted from everywhere but /Applications/MAXON/CINEMA 4D R17/plugins. If that does not help, there would be a remote possibility that the plugin has been corrupted when downloading/unzipping, or has been copied over an existing folder from an earlier plugin version (thereby resulting in files from the two versions being present), in which case, the solution would be to delete the plugin folder, re-download, unzip, and install again.

If none of this helps, then please delete the plugin and make sure that Cinema once again starts as normal; if not, I would try deleting or renaming the Cinema Preferences folder. Once Cinema is running, please let me know exactly which version of Cinema you are using, and also exactly which version of OSX, because here, the plugin is running just fine.

Regarding your further post about Windows, this message should usually indicate that you have two versions of the plugin installed at once. Parts of the plugin are given unique IDs, which don't change with plugin version, and this prevents the possibility of running two versions of the same plugin at once.
#388632
Hi

I did try two locations, the first one being the Preferences folder, which I can locate by going to Preferences in Cinema and there is a button at the bottom part of the window. The second one was the plugins folder in /Applications which you mention. The confusion came from me in my initial post quoting just the preferences folder and omitting that last 'plugins' subfolder. Anyway, I've tried these two folders:

1: /Users/bjorn/Library/Preferences/MAXON/CINEMA 4D R17_89538A46/plugins (this is the folder where I have all my other plugins installed btw)
2: /Applications/MAXON/CINEMA 4D R17/plugins

Since my last post, I've now upgraded to El Capitan instead of Yosemite but experience the same issue. Cinema 4D stalls on launch when it comes to "Loading plugins" and I have to force quit it after a few minutes of waiting.

After that I've now tried to remove all plugin folders, and yes Cinema starts again. I'm re-downloading it as I write this, and will try that aswell.

My Cinema 4D version is R17.032 build RB139719 and OS X 10.11.

Regarding the Windows problem: I see! thanks, I've solved that now.
#388635
Not sure what to tell you, it sounds like there is no error message, just an apparent hang during startup. You might try opening /Applications/Utilities/Console to see if anything suspicious is logged during startup, and also looking in Activity Monitor, to see what the Cinema process is doing (CPU-wise) during that time. That, and you might try using Disk Utility to repair permissions, I suppose, on the off chance that Cinema's not allowed to access part of the plugin, or something of that nature.
#388636
Hi

Thanks for these troubleshooting steps,. I've tried this now:

Repair disk persmissions seems gone in El Capitan, but I did something called First aid in Disk manager instead. Cinema still gets stuck now, but possible on "Initializing plugins" instead of "Loading plugins". But I can just aswell be mistaken on this points, I don't trust my memory.

During launch,, Cinema peaks in CPU until it get red marked in activity monitor and marked as "not responding".

Console prompted these three messages when I launched cinema. Not sure if it's related at all.

05/10/15 23:06:26,555 mDNSResponder[102]: handleLNTGetExternalAddressResponse: Router returned bad address
05/10/15 23:06:26,557 mDNSResponder[102]: handleLNTGetExternalAddressResponse: Router returned bad address
05/10/15 23:06:26,559 mDNSResponder[102]: handleLNTGetExternalAddressResponse: Router returned bad address

And then when the crash was imminent:

05/10/15 23:07:57,000 kernel[0]: process CINEMA 4D[1436] thread 63259 caught burning CPU! It used more than 50% CPU (Actual recent usage: 93%) over 180 seconds. thread lifetime cpu usage 90.018749 seconds, (85.536002 user, 4.482747 system) ledger info: balance: 90000002563 credit: 90003526999 debit: 3524436 limit: 90000000000 (50%) period: 180000000000 time since last refill (ns): 95816535560
05/10/15 23:07:57,428 com.apple.xpc.launchd[1]: (com.apple.ReportCrash[1437]) Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in(): com.apple.ReportCrash
05/10/15 23:07:57,429 ReportCrash[1437]: Invoking spindump for pid=1436 thread=63259 percent_cpu=93 duration=97 because of excessive cpu utilization
05/10/15 23:08:00,024 spindump[794]: Invalid connection: com.apple.coresymbolicationd
05/10/15 23:08:02,560 spindump[794]: Saved cpu_resource.diag report for CINEMA 4D version 17.0 (17.0) to /Library/Logs/DiagnosticReports/CINEMA 4D_2015-10-05-230802_Morris.cpu_resource.diag
05/10/15 23:09:22,000 syslogd[48]: ASL Sender Statistics
#388638
Hi again

Now, without changing anything, looking at the screen - Cinema has started. I tumble in the view just to confirm it's responsive. Maxwell plugin is there aswell. I then close it, and restart it just to confirm it now apparently works - which is does not. I have not been able to start it again.

This is weird.
#388640
It certainly appears strange, and I'm guessing, localized to your particular machine. Since your last post, I've been looking into what it might possibly mean for the OS to log that "thread 63259 caught burning CPU!" message, while it is in the process of shutting down the process "because of excessive cpu utilization" (whatever that is supposed to mean -- we buy machines to use them, not have them sitting idle).

Whatever the case, I don't think it is likely the plugin itself using much CPU at that time, and I'd look at whether there is some type of anti-virus installed, or any other type of software that is capable of injecting itself into other processes. On the other hand, not all of the code in the plugin is actually the plugin's own code; it seems possible that, for instance, something in the RLM code could conceivably be trying to scan networks, or something like this, so I'd try to simplify the environment (removing network shares, thumb drives, extra input devices, etc) as much as possible, just to see if I could produce a change in behavior.
#388725
Hi again

Now I've tried removing the plist file and a plist.lockfile in ~/Library/Preferences folder. after that Cinema does not stall on startup, but instead crashes with an error, so that is one step forward I guess :)

Here's the image of the error. I might try re-installing cinema now. Just want to make sure I get rid of all old stuff spread around the harddrive.

Image
#388726
That is just the dialog that is shown when Cinema crashes (if it thinks a plugin is causing the crash, it will mention that plugin in the box). You should be able to navigate to the file (_BugReport.txt) mentioned in the error to see some information about the crash.

As far as I know, it should be fine to delete every single Cinema-related thing you can find on the machine, because things like plist files, and the Cinema Preferences folder (the one mentioned in the crash dialog), should all be created on-demand the first time Cinema is started, and should be re-created as necessary. At least, I know that many times, I have copied the entire Cinema folder from /Applications to a new machine, and then run it, and all works fine, after I put in my license info. However, I technically can't guarantee anything, because it's plausible that you could get the application into an indeterminate state by having deleted some, but not all, such files, so that it wakes up in a twilight zone that it's not prepared to handle.

Probably the use of two "." in the file […]

Maxwell and Blender

An addon for Blender would be amazing. It would in[…]

Hey Patrik, thanks for the suggestion. 🙌🏼 Creams […]

Hi ki_cz, this is my attempt with another engine,[…]