User avatar
By stir
#381571
have some one had a similar problem, where the xmesh turns black in the render?

Its a bit complicated to explain but i'm going to try.

You build up a scene with multiple xmeshes.
they are all shaded and ready to go.
I do a test render locally and everything is fine.

Image


Then i export a mxs sequence and send it to the farm.
When i look at the result all the xmeshes looks good except 1. one of them is black.
and it stay black for a while, until it suddenly is fine to.

I dobbel checked the xmesh, and the normals are pointing the right direction, the smoothing groups are fine. There is really no reason for it to behave like that.
I also checked if it was some serten slaves that had the problem, but it wasn't that either since it was black for the 50 first frames and fines the 100 last.

what solved it tho was to add a edit poly modifier on top of the xmesh loader.
why that fixed it i got no clue, was maybe hoping someone here could give it a reasonable explanation.

anyways. if some one experience black xmeshes, try add a edit poly on top of it.

if you don't know what xmesh is, you can read about it here http://www.thinkboxsoftware.com/qr-xmesh/


-Mats

Hi there, after a texture tag has been assigned to[…]

Rhino6 Plugin / Rhino Crash

Having fun on my own thread here :) It appears tha[…]

The script will be useful and i think it is easy t[…]