Everything related to SDK.
By texsetter
#78481
Hi,
i have to create a bundle to use maxwell with my application. (the plug-in is loaded at runtime).

Two problems with sdk 1.2.2a

I'm using gcc 4.0.0 and gcc 3.3, xcode 2.1 on osx 10.4.3.

1) To link with the library i must execute runlib on the libraries first; gcc gives me this error:

table of contents for archive: osx libs/gcc/libmaxwellg5.a is out of date; rerun ranlib(1) (can't load from it)

2) after that the linker gives me this error:

libmaxwellg5.a(rgb.o) has local relocation entries in non-writable section (__TEXT,__text)

the same with libmaxwellg4.a, also using gcc 3.3.

All works fine if i create an application (static executable), but with a bundle (like a dll on windows) i get the error.


Any ideas ?

tnx texsetter

Good day! We have just uploaded a new version of […]

Hey Kev, I believe it doesn't work in Maya's plugi[…]

Maxwell and Blender

Blender 2.9 is out - has there been any further pr[…]

I think that most features that are needed on a re[…]